Question Missing Front Panel Connectors & CPU is stuck

Aug 22, 2019
4
0
10
0
I am currently building my first gaming PC and I have a question regarding the front panel connectors. I am brand new to all of this so forgive me if this is a stupid question. But I am currently trying to connect my front panel connectors and I only have one, which is Power SW. From all the youtube videos and guides I have watched, there always seems to be several of these that include LEDs, USBs, and a reset switch. But I only have the Power SW. I believe it may have something to do with having a newer case but I am not sure. My case is Phanteks 350x, the rest of my specs are as follows:

AMD R5 2600x
GTX 1660ti
16gb DDR4 3000mz RAM (2x8)
MSI b450m Pro-VDH mATX mobo
500gb SSD and 500gb HDD
550w PSU

Thank you to anyone who can help as all of this is stressing me out!
 
Last edited:
That case only does have a power switch, no reset and the only LEDs plug into a dedicated digital RGB header that only some ASUS and MSI motherboards have (yours should be marked JRGB1). You should also see a blue USB 3.0 header plug, audio, and a SATA power plug that attaches to the PSU.

Follow the cables from the front USB ports and audio jacks back to where they are probably all taped up to avoid scratching during shipping.
 
Aug 22, 2019
4
0
10
0
That case only does have a power switch, no reset and the only LEDs plug into a dedicated digital RGB header that only some ASUS and MSI motherboards have (yours should be marked JRGB1). You should also see a blue USB 3.0 header plug, audio, and a SATA power plug that attaches to the PSU.

Follow the cables from the front USB ports and audio jacks back to where they are probably all taped up to avoid scratching during shipping.
Very helpful. I will check all of this. Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS