Mobo dead? Any help?

Deeyou

Distinguished
Dec 5, 2011
25
0
18,530
Hey folks,

I have a raidmax tower that the power sw broke on. I couldnt turn it off so I left it on continuously. This morning my daughter climbed on the tower and dislodged the faceplate.

I don't know if it shorted the front usb hub from the wire getting pulled. But I got the usb power exceeded error. And everytime I closed it, it would pop back up. So I selected "reset" on it. And it shut my comp down.

I couldn't power it on by the switch, obviously. So I tried to jump the ps on the com block to no avail. I tested the psu by jumping the PS ON pin to one of the com block pins and it fired up the fans and all my HD's

But when I connected the atx harnesses and tried to jump the ps again...nothing...

I cleaned and purified the cpu surface. Put fresh thermal paste and reseated, reseated the cmos, reseated the ram and checked for bulging or leaking caps. Still wouldn't power up.

Then I jumped the PS ON pin from the atx to the power sw pins and plugged the harness in...when turned on I have power to the front usb hub, the cpu fan, the hdd light and case lighting. But the monitor will not come on and wont post. And I get no power to the keyboard, mouse and ethernet ports...the rear usb works fine however.

Im at a loss now of what it could be...