Question Mobo dead sata port? Causing extremely bad behavior

Jul 9, 2020
1
0
10
0
This is slightly long, I'm going to make an effort to break down the road map of issues as succinctly as possible.

Woke up 5 days ago, main SSD had failed completely, greeted with "Insert Boot Media" screen on startup. Believed at the time to be a simple SSD failure, tried SSD in other device, does not appear/recognize, seems bricked. Thought this was just that.

Installed Windows 10 to backup 128 GB drive. Initially worked fine. Bought a new 1 TB SSD, installed in same port with same power plug and SATA cable as old drive- Did not recognize. At this point I begin to suspect the sata cable is damaged or that the mobo has a damaged port. Moved cords around, and in my not paying attention I plugged the backup drive that contained Windows into the sata cable attached to the bad port (or bad cable). Powered on, Windows immediately posts to the "Something Has Gone Badly Wrong" with an error code indicating my kernal file had been corrupted/damaged/gone missing. Knew what I'd done immediately, powered down.

Here's where <Mod Edit> gets weird and bad. Clean windows install, reformatted without clean wiipe, windows very very slowly boots in, after an hour of setup (On an SSD), everything is insanely slow. I install my drivers, restart. Insert Boot Media, immediately dead windows. Diskpart Clean wipe this time, reformat. Takes ages again. Boot into windows finally, install updates, etc. Seems "Stable" but is still doing some tasks extremely sluggish. Restart takes longer than you would ever expect for an SSD. Once it "gets going" though it seems to be acting normally.

Other issues: Mobo is erratic in detecting bootable drives. On some starts it will detect Drive 1,2,4 but not 3. Another restart, media 2,3,4 but not 1. Seems totally random. Boot menu has random 'blank' entries for selectable bootable drives. That slot is obviously damaged, or the SATA cable is. I have one on order, but I'm still dealing with what I think is a pretty serious underlying problem, but I don't know what and i've reached the end of my expertise.

I know that was too long, sorry. Thank you for any help. Specs: Z170X Gaming-7 MOBO, 16 gigs ram, radeon 580, windows 10, i7-7700 3.60ghz

Edit: On reboot I'm now getting a screen saying my boot information is wrong- Error 0xc0000185, hitting enter enough times pushed past it but it's definitely not going well.
 
Last edited by a moderator:

ASK THE COMMUNITY