MOBO intermittently not recognising SSD with OS on


Jan 27, 2012
I have the following:

Asus Mobo: P6X58D-E
SSD: Corsair CSSD-R60GB2
x2 Seagate 7200rpm 500g Sata3
PSU: 850w

The mobo's BIOS was just updated to the latest Ver.

The OS is on the SSD. All games etc are stored on the Seagates (in Raid0)

The MOBO has x6 SATA2 ports and x2 SATA3 ports.

Normal config is:
The CDROM drive + SSD are connected via SATA2 (have tried alternating ports)

The Seagates are connected into the SATA3 ports

From time to time i get the following problem:

The SSD is not recognised one the boot screen and then i'm presented with:

'Reboot and Select proper Boot device'

Sometimes it is recognised but the message still appears unless i press F8 and manually select it

Sometimes it boots properly.

I've tried the SSD in an external HD casing and it works everytime.

In my head i've ruled out:

bad cables (have tried many different ones)
bad SSD (works within the external)

As you can probably tell from the layout of my 'troubleshooting' i'm not that experienced in putting PCs together and troubleshooting issues.

I've tried to google Asus motherboard/SSD problems with no real success.

Can anyone put me on the right path?

Thanks in advance