Question Mobo issue with ethernet?

Sep 24, 2020
3
0
10
0
My ethernet stopped working a few months ago. I decided to try an usb to ethernet adapter. Didnt work. So my last thought was a PCI E ethernet card. That didnt work either. I tried different ethernet cables but that didnt seem to help. It doesnt make sense that the other things i tried didnt work. Is my mobo just fried on the ethernet side?
 
if it works, update windows before rebooting again

What exactly does not work?

Is the flight mode disabled in windows?

Is the ethernet adapter showing up in device manager?

upload a picture of the network status, like:
https://www.bleepstatic.com/images/news/Microsoft/windows-updates/wifi-adapters/network-status.jpg


Do other ethernet devices work with your router/modem?
 
Sep 24, 2020
3
0
10
0
I'll have to check for the flight mode tomorrow but I'm pretty sure it's off. The link did not fix for me. The adapter Is showing but when I run a diagnostic it says no ethernet is plugged in. The upload image would be the same as what you posted. I have no other devices through ethernet. I got a new router when the ethernet stopped working and still the same on the new one.
All adapters show a red x on them and all give the message to make sure an ethernet cable is plugged in. Tried 2 cables and bought a new one neither worked.
 
Sep 24, 2020
3
0
10
0
Would usb work? I have no cd drive. Why would a new pci e card and ethernet adapter not work if its just a dead port. But yeah my mobo is 4 years old
 

ASK THE COMMUNITY

TRENDING THREADS