Question Mobo stuck on red boot light ?

Apr 28, 2021
1
0
10
0
I’ve been trying to rebuild this pc for several days now and thought I had figured out all the issues. Put a brand new psu and brand new mobo in it. The other day it would boot to bios and desktop fine (couldn’t do anything from the desktop as the mobo isn’t windows 7 compatible and that’s what I had on the hard drive) Now today I go to boot it up to do a clean install of windows 10 and I’m back to getting no display and the red status led on the mobo is stuck on boot, what’s going on here?

Things I’ve tried:
Reseated ram (with more than one stick slotted the red light hangs up at ram, tried multiple slots)
Reseated gpu
Checked connections from psu to components
Confirmed monitor works
Tried multiple sata cables and ports
Mobo: Gigabyte z390 gaming x

CPU: I7 8700k
Gpu: msi R9 390
Psu: Evga 850 gold
Ram 2x 8gb Corsair vengeance ddr 4 3200mhz
Hdd: 1tb seagate (not really sure beyond that, never really had packaging for it)
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

EVGA is the brand of the PSU and 850W is the wattage of the unit. What series is it from(i.e, it's model) and how old is the PSU? Did you fabricate your bootable installer using Windows Media Creation Tools? You might want to try and breadboard the system, remove the CMOS battery and then replace it after 30 mins. It might even be possible that your HDD has given up the ghost.
 

ASK THE COMMUNITY

TRENDING THREADS