[SOLVED] Mobo wont post in dual channel

Feb 3, 2020
8
0
10
0
I have an Asus X-470 Plus Gaming mobo and Crucial Ballistix 2x8gb 3000mhz

I cant get to post in dual channel mode. I can post with one and both sticks of ram in single channel mode.
I know most people would say I have a bad mobo, that's what I thought but this is the second board this happens with. I sent the original back and got a replacement and the same thing happens. Before I sent the original back in I checked the CPU pins on the board and none of them were bent. The board supports this speed of ram so I'm not sure whats going on.

I'm not sure if this has to do with anything but I am using a ryzen 3 2200g on BIOS 4012, yes I know the BIOS is a bit dated but from what I've read its best to leave it if it works?

Any help is appreciated because I am looking to upgrade my CPU at some point but feel it isn't worth it if I cant even run dual channel memory.
 
Last edited:

Zizo007

Respectable
Feb 23, 2019
1,681
236
2,290
55
Yes I bought it as a a 16gb kit(2x8gb sticks). The # for the ram is BLS2K8G4D30BESBK
And to be honest I cant even find a part number that matches directly up with the one I have on Crucial/ballistix website. Which could be the problem lol
I have tried all combinations with the ram but it will only post with A1/A2 occupied.
You RAM is not compatible with your motherboard according to Asus website (Select the Ryzen with Vega list):
 

Zizo007

Respectable
Feb 23, 2019
1,681
236
2,290
55
First as Popatim said, did you buy your RAM as a kit?
Second, in which slots are you putting your RAM? Depending on the motherboard they should be A2/B2.
Third, is your RAM in the QVL memory compatibility list of your motherboard?
 
Feb 3, 2020
8
0
10
0
Yes I bought it as a a 16gb kit(2x8gb sticks). The # for the ram is BLS2K8G4D30BESBK
And to be honest I cant even find a part number that matches directly up with the one I have on Crucial/ballistix website. Which could be the problem lol
I have tried all combinations with the ram but it will only post with A1/A2 occupied.
 

Zizo007

Respectable
Feb 23, 2019
1,681
236
2,290
55
Yes I bought it as a a 16gb kit(2x8gb sticks). The # for the ram is BLS2K8G4D30BESBK
And to be honest I cant even find a part number that matches directly up with the one I have on Crucial/ballistix website. Which could be the problem lol
I have tried all combinations with the ram but it will only post with A1/A2 occupied.
You RAM is not compatible with your motherboard according to Asus website (Select the Ryzen with Vega list):
 
Feb 3, 2020
8
0
10
0
Well that would be a problem wouldnt it lol!
Guess Im in the market for a new ram kit!
Seems like the memory support of this board is its downfall?
Ive seen alot of bad reviews since I got this board
 

Zizo007

Respectable
Feb 23, 2019
1,681
236
2,290
55
Well that would be a problem wouldnt it lol!
Guess Im in the market for a new ram kit!
Seems like the memory support of this board is its downfall?
Ive seen alot of bad reviews since I got this board
Yea its memory compatibility sucks.
TUF is Asus's midlevel motherboards, they aren't as good as their highend. I would have bought an MSI B450 Tomhawk Max and it would have been cheaper and better.
 

ASK THE COMMUNITY

TRENDING THREADS