Question Mobo zapped? Lights, fans, no display

Apr 22, 2019
2
0
20
1
Fuming right now
Had half a build set up in one case, move it to a smaller phanteks shift. Mobo and CPU worked fine in 1st case, only parts that changed were the PSU and graphics card. Plug in my finally complete build and no output. Tried swapping ram, clearing cmos, it's a ryzen so no integrated graphics but god damnit I tried anyway.
If anyone can think of something to fix this so I don't have to drop another $150 on a new motherboard I would marry you
System is:
Ryzen 5 2600x
Rtx 2060
Aorus pro wifi
Some cheap ram 16gb
Corsair sf600
 

Darkbreeze

Titan
Moderator
Check both ends of the display cable and the sockets they plug into for bent pins. Happens all the time.

Try a different display cable. I can't count the number of times I've seen users chase a problem for days only to find it's a cable issue and that they actually DID have a display output, it just wasn't making it to the monitor. Also, maybe try another monitor, just to be sure, if you happen to have one.

If the cable or cable pins are not the issue, remove the CPU and check for bent pins. This is the MOST likely problem, even if it worked in the first case. A CPU with slightly bent pins can still work, but can stop working over time due to vibration making breaking the contact between the bent pin and the contact points OR moving the hardware can do the same thing. Best to check and eliminate that possibility before going any further trying to track down an issue.

Make sure the memory is installed in the A2 and B2 slots, which are the second and fourth slots away from the CPU socket. All dual channel boards for the last ten years or so use those two slots when only two DIMMs are installed. "Swapping RAM" means nothing. It needs to be, MUST be, installed in the correct slots as seen here. Obviously for boards with only two DIMM slots, it doesn't apply.



It would also be helpful to know the exact model number of the memory kits involved AND whether you've tried EVERY SINGLE STICK, by itself, with no other sticks installed, and IN the A2 slot.

Short of that, I'd pull the board and check to see there is not a standoff in the wrong place, as outlined here in my guide.

 

ASK THE COMMUNITY

TRENDING THREADS