• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Modem throttled to 100 mb/s when 2.4ghz wifi is on

Nov 13, 2019
5
0
10
0
As the title states, I cant get internet speeds over 100 mb/s when the 2.4 ghz wifi is turned on. The modem internet light turns solid orange. When I turn off 2.4ghz wifi on the router, the modem internet light stays green and I get the speed I am paying for.

Modem: Netgear cm 600
Router: Netgear R6700 flashed with dd-wrt with March 2019.
 

Ralston18

Titan
Moderator
On your computer: Do you have both the wired and wireless adapters enabled?

Should be only one adapter or the other. Wired or wireless not both at the same time.

If I follow correctly, you are using/have a wired (ethernet) connection between the computer and router.

Wired speed/performance is as expected.

But when 2.4 GHz is turned on the computer reverts to the wireless adapter and slower performance.
 
Nov 13, 2019
5
0
10
0
Thank you for the reply. Maybe I didn't explain myself very well. The Netgear modem is being throttled back by maybe the router or itself? I am not running a PC with a wired and a wireless connection. I have 25 smart switches and devices that only run on 2.4 ghz wifi. These are the only things that connect to the 2.4 ghz wifi. If I open DD-WRT and turn off the 2.4 ghz wifi, my modem runs un-throttled.
 

alceryes

Distinguished
This could be a DD-WRT bug. It sounds like the network connection between your modem and router is dropping from 1000Mb to 100Mb when you enable the 2.4GHz wifi frequencies, per your description of the light color changing.

What is your rated internet speed?
 
Nov 13, 2019
5
0
10
0
My internet speed is 256 mb/s. I have ran speed tests with the 2.4 ghz on and off. The results are where I believe they should be with the 2.4 ghz off and less than 100 mb/s when it is on. I have been leaning towards your comment about the DD-WRT bug. I figured maybe I have something ticked in the firmware that could be causing it.
 

alceryes

Distinguished
I figured maybe I have something ticked in the firmware that could be causing it.
I guess this is possible but I can't think of a reason this would even be accessible as a setting or why you would want to change it.
Do you have any hard coded 100/full or 1000/full physical port options anywhere? It's been a while since I used DD-WRT and they are always changing/adding things but I don't remember seeing this as an option previously. Maybe there's an option that is erroneously changing when you enable 2.4GHz wifi.

Edit - I guess it makes sense to have this option available in the rare cases that you are dealing with a media converter or straight fiber with an SFP where auto/auto can sometimes (very rarely) cause issues.
 
Nov 13, 2019
5
0
10
0
I am at work now but will check into that when I get home. Looks like I may have to flash the stock firmware just to rule out a few things. Thank you for your help.
 
Nov 13, 2019
5
0
10
0
I believe the issue was the ethernet cable between the modem and router. I replaced it with a 5e. I think when the 2.4 ghz was on it was too much traffic for the old cable (27 smart devices). Someone correct me if this would not be the case.
 

ASK THE COMMUNITY

TRENDING THREADS