Question Monitor acting funny after system restore

mmejido

Reputable
Oct 2, 2017
25
0
4,530
0
Hi everyone.

I recently did a system restore on Windows 7 64. It didn't restore properly, and my monitor settings have been a bit screwy since.

a) When my computer boots up, dos doesn't fully fit on the screen
b) When I try booting into windows safe mode, it doesn't load (but it'll load if I unplug my laptop from the dock/monitor and use my laptop monitor)
c) The display settings didn't even see that 1920x1080 was available for windows 7. I did a custom monitor profile and am not currently seeing windows 7 in 1920x1080.

How can I fix this? :(
 

mmejido

Reputable
Oct 2, 2017
25
0
4,530
0
reinstall the gpu driver?
Well, the issue is with the external monitor - sorry, should have been clearer.

I just confirmed that everything works perfectly when I use the laptop with its built-in monitor. Resolution on bootup in DOS is perfect. It reads that the monitor's resolution is 1920x1080 perfectly.

Back on external monitor now (its an old Samsung B2430HD on a VGA cable). Still booting up in DOS weird. Still not reading the 1920x1080 resolution as native except for the custom profile I made.

I installed the monitor's drivers. Searched for updated drivers using windows 7. I don't see any change - it still doesn't recognize that 1920x1080 is one of its available resolutions.
 
Last edited:

mmejido

Reputable
Oct 2, 2017
25
0
4,530
0
Update: I've now tested it out with:

a) the built in laptop monitor
b) another external monitor

both go to the regular resolution of 1920x1080. My current external monitor still doesn't. When windows 7 loads up, dos is still off the screen. I still have to do a custom profile for 1920x1080 in the NVidia control panel.

I can work like this of course, but I just don't like having unresolved issues that I know can be fixed laying around. Can anyone help?
 

ASK THE COMMUNITY