Monitor and Keyboard shut off at random. PC stays on.

Jaw327

Reputable
Aug 4, 2015
35
0
4,530
0
Had this problem for a while and thought I fixed it but it has started up again and is driving me crazy.

What will happen is my monitor and my keyboard will suddenly shut off, while all my case lights and fans, etc stay on. The PC is clearly still running but monitor and keyboard are off. Can't turn off the PC either, have to flip the switch on the back.
Also the motherboard light that is normally green becomes blinking orange.

Worried it is a motherboard failure or some kind of power surge. This started happening a while ago and I thought I just had an unstable overclock. Went back to all base settings with my CPU, etc and seemed like things were fine but it has now started happening again.
It's at completely random times. Computer could just be sitting on with nothing happening, could be gaming, could be running Premiere Pro or just online.
Saw a couple other people on here with similar problems, didn't see that anyone had definitively figured it out. Any help/ideas would be greatly appreciated.
Thanks

Some components
Ryzen 1700x
MSI GTX980ti
ASUS ROG STRIX X370
EVGA SuperNOVA 850 G3
 

Jaw327

Reputable
Aug 4, 2015
35
0
4,530
0


you mean just the wall outlets? Usually the PC and Monitor are both plugged in to a surge protector/powerstrip. Right now I actually have the monitor plugged in to a separate wall outlet from the PC
 

Jaw327

Reputable
Aug 4, 2015
35
0
4,530
0


ohh no, I don't think that's what's causing it as it has happened at two separate locations. But I'll double check my voltages to be sure
 
Sep 13, 2018
12
0
20
2
Hmm, It's quite possible it's the motherboard, but to me it sounds more like an issue with your psu. Motherboards are rather difficult to kill these days thankfully :)

If you've got a spare psu lying around, I suggest testing your pc with that and seeing if the issue goes away.
 

Jaw327

Reputable
Aug 4, 2015
35
0
4,530
0


yeah I'm kind of thinking the same. I don't have a spare power supply unfortunately but might go ahead and order a new one and see how it goes
 

Jaw327

Reputable
Aug 4, 2015
35
0
4,530
0


it is updated, but only recently. I thought maybe that was the issue so updated the bios, I think it's version 4012 or something like that but the problem has persisted.

I just reset my CMOS, swapped around the RAM sticks and made sure all my PSU cables were neat and snugly plugged in, so we will see what happens.
 
Sep 13, 2018
12
0
20
2


Go for it man! Hope it fixes your issue :D
 

Jaw327

Reputable
Aug 4, 2015
35
0
4,530
0
EDIT: NOPE NOT SOLVED.

ok I think I've maybe solved this issue (for me at least) in a rather unlikely way.
I talked to ASUS but they weren't much help. Wouldn't replace my motherboard and wanted me to send it in for testing.
But anyway the solution appears to have been with my keyboard.
It's a Corsair K70 Deluxe RGB whatever keyboard and the USB cable out of the back splits into two. They say you don't need to use both USB if you are plugging in to USB 3.0 slots. I always just plugged both in because I didn't like the other one hanging free near the back of my PC but for whatever reason I unplugged the unnecessary one and now... for like 3 days haven't had the problem. Seems crazy but also seems to be fixed (hopefully)
 

ASK THE COMMUNITY

TRENDING THREADS