Question Monitor, and USB. How to fix?

Wolfgang_2

Prominent
Jun 26, 2017
5
0
510
0
Hello,

Recently, i decided to make some changes to my radiotor fan configuration because i wasnt really happy with the temp. But, that ended up being a waste of time.
I left my computer sitting at my desk overnight afterwards because it was pretry late when i reinstalled everything. Come the next day, i decide to plug everything back in and use my computer as i usually would. Here's the problem. My computer wont connect to my monitor via DP, nor do any of my peripherals power on after plugging them in via USB. Ive tested the USB ports for power using a phone charger, and even a E-cig charger i had laying around and they worked perfectly. For some odd reason my mouse, keyboard and monitor wont work. I've looked around to see if i can find some ways to fix this. But i cant seem to find anything that explains both of these problems. If any of you guys have any tips, or ideas on how to fix this, please let me know.
Specs:
Gpu - Gigabyte Geforce GTX 1080
Mobo - Asrock Z270 Extreme 4
CPU -Intel i7 7700 Kaby Lake
Radiator - Corsair H115i Pro
PSU - EVGA 650 G2
Monitor - Dell S2716DG
 

Ralston18

Titan
Moderator
Get the motherboard's manual and double check that:

1.) all connections and cables are correctly placed.

2.) all connections, cables, cards, jumpers, etc. are fully and firmly in place.

How old is the PSU? If you have been generally upgrading then the power requirements likely went up while the PSU declined.

And any SSD and HDD's are also a load on the PSU. What drives do you have?
 

Wolfgang_2

Prominent
Jun 26, 2017
5
0
510
0
Get the motherboard's manual and double check that:

1.) all connections and cables are correctly placed.

2.) all connections, cables, cards, jumpers, etc. are fully and firmly in place.

How old is the PSU? If you have been generally upgrading then the power requirements likely went up while the PSU declined.

And any SSD and HDD's are also a load on the PSU. What drives do you have?
I have to drives. A Samsung 970 EVO M.2, and a WD Black 2TB. The entire rig was built around Fall 2017, so its fairly new, kinda. I'll unplug everything and open it up to chck the connectors now. Thanks.
 

ASK THE COMMUNITY

TRENDING THREADS