Question Monitor detected but not active

Jan 10, 2020
8
1
15
0
Sorry for bad english.
Here is my story:
Today i turned on my computer and noticed that only one of the 2 monitors i have turns on(only the secondary). Since then I've tried doing these things in order:
1.get a new cable
2.reseat my gpu
3.DDU my drivers
4.Reset CMOS
5.system restore(I did this because of a boot loop that was caused by me forgetting to turn on rapid storage)

I tried both changing settings in nvidia controll panel and display settings. When saving settings my pc would freeze for a second and it would either say that it was unsuccessful or it would just do nothing.

In device manager i see no yellow signs i only see 2monitors with the name generic PnP.
The gpu has 2 display ports and it doesn't matter wich one i plug it in.
Specs:
I7 6700k
GTX 1070
Windows10
Also the monitor works when i plug it in with hdmi only doesn't work when its DP.
Thanks for help in advance.
 
Last edited:
Jan 10, 2020
8
1
15
0
Since then i have tried putting my gpu into a windows7 machine.
Here are some tests i did:
-Both hdmi monitor and DP monitor plugged in:neither works

-Only hdmi monitor:works with no issues

-Only DP monitor:no signal

-Only hdmi monitor and plugging in DP after boot: both monitors detected but can't change the settings of DP monitor and no signal.When clicking on "identify" setting the DP monitor turns on just to say that there is no signal so it definitely is detected. It doesn't have signal even while booting so it probably isn't a software issue.


All i can think is that maybe the DP port is broken somehow.
 

ASK THE COMMUNITY

TRENDING THREADS