Question Monitor doesn't connect to laptop when the HDMI is connected between them

Mar 18, 2019
2
0
10
0
This has been absolutely puzzling me and everyone I have asked for the past day so I thought I'd come on here and see if I could get some help. Recently when I tried to play a game my monitor went black and act as if nothing was connected to it. Since then, my monitor has either not connecting to my laptop at all or disconnected from my laptop after about a minute of it running. The monitor is an OMEN (not sure which version though I could probably find out if it is that important).The really weird thing is this: I use an HDMI hub since I use multiple devices on my monitor, and the two other devices connected to the hub work on the monitor but my laptop does not. The hub even gives me a light telling me that my laptop and monitor are plugged into the hub and working.
I have tried:
-Using another HDMI cable
-Plugging the HDMI cable directly into the monitor
-Uninstalling and reinstalling my graphics drivers
-Updating my graphics drivers
-Rolling back the update of my graphics drivers
-Connecting my HDMI to another monitor (it still didn't work)
-Factory resetting my monitor
I'm at the point where I am about to factory reset my PC, if anyone has anything that might help, it would be amazing.
 
This has been absolutely puzzling me and everyone I have asked for the past day so I thought I'd come on here and see if I could get some help. Recently when I tried to play a game my monitor went black and act as if nothing was connected to it. Since then, my monitor has either not connecting to my laptop at all or disconnected from my laptop after about a minute of it running. The monitor is an OMEN (not sure which version though I could probably find out if it is that important).The really weird thing is this: I use an HDMI hub since I use multiple devices on my monitor, and the two other devices connected to the hub work on the monitor but my laptop does not. The hub even gives me a light telling me that my laptop and monitor are plugged into the hub and working.
I have tried:
-Using another HDMI cable
-Plugging the HDMI cable directly into the monitor
-Uninstalling and reinstalling my graphics drivers
-Updating my graphics drivers
-Rolling back the update of my graphics drivers
-Connecting my HDMI to another monitor (it still didn't work)
-Factory resetting my monitor
I'm at the point where I am about to factory reset my PC, if anyone has anything that might help, it would be amazing.
It sounds like the port "just" died like said im done no more you may have been over loading it laptops ports arnct meant to taking the power hungery consumption of "several" devices
 
Mar 18, 2019
2
0
10
0
It sounds like the port "just" died like said im done no more you may have been over loading it laptops ports arnct meant to taking the power hungery consumption of "several" devices
That doesn't really make sense to me though since the HDMI hub can detect both the monitor and the laptop being plugged into it (the HDMI hub also detects when certain devices are on or off so I would assume if the port wasn't working then there wouldn't be a light showing in the HDMI hub)
 

ASK THE COMMUNITY