Question Monitor flickering with new 1660 Super DP port

Jul 27, 2020
2
0
10
0
I just upgraded to a 1660 Super from my 970. Whenever I use the DisplayPort with my primary monitor, I get sporadic flickering across the bottom couple inches of the screen. The HDMI port works fine. I already sent the card back for a replacement as well as trying a new DisplayPort cable. I don't have any other monitors with DisplayPort to test on.

I can't get a picture of the flickering because it's so brief. It happens every 3-10 seconds, flickers for less than a half-second, and it almost looks like the pixels are all being displaced. Parts of the image will shift to the left or right, but some parts will stay where they belong.

I can't figure out how to stop the flickering, any help would be appreciated.

Mobo: ASUS M5A99fx 2.0
CPU: AMD FX-8350
GPU: GTX 1660 Super
Monitor: ASUS PB278Q @ 2560x1440
 

poorbugger

Reputable
Nov 28, 2015
463
61
4,790
9
I just upgraded to a 1660 Super from my 970. Whenever I use the DisplayPort with my primary monitor, I get sporadic flickering across the bottom couple inches of the screen. The HDMI port works fine. I already sent the card back for a replacement as well as trying a new DisplayPort cable. I don't have any other monitors with DisplayPort to test on.

I can't get a picture of the flickering because it's so brief. It happens every 3-10 seconds, flickers for less than a half-second, and it almost looks like the pixels are all being displaced. Parts of the image will shift to the left or right, but some parts will stay where they belong.

I can't figure out how to stop the flickering, any help would be appreciated.

Mobo: ASUS M5A99fx 2.0
CPU: AMD FX-8350
GPU: GTX 1660 Super
Monitor: ASUS PB278Q @ 2560x1440
I've heard of people fixing this by doing this. Dont turn off your monitor. Unplug the power cord from your monitor straight and wait for a few minutes. Then plug it back in
 
Jul 27, 2020
2
0
10
0
Thanks for the try, but no go. I gave it about 10 minutes and plugged it back in with no change. I don't understand what's different about the DisplayPort connection from my new 1660 to the old 970. The 970 was a different manufacturer and with 2 less GB of VRAM, but I don't see how that would matter as far as the display goes.

Could it be something to do with the fact that it's a newer version of DisplayPort on my GPU than my monitor? I know they're supposed to be backward compatible, but I just don't understand what else could be causing a problem here.

Also, I took a video of the flickering on my phone, but I don't know how I would post it.
 

ASK THE COMMUNITY