Monitor loses signal and then whole pc freezes

Jul 5, 2018
2
0
10
0
Hello,

I'll start off by saying my pc isn't new - it's like 2-3 years old. The issue came up 3 days ago or so, i hadn't used it for a week prior.

The issue :

At random times my monitor loses signal to my pc, but i can still talk for example in TeamSpeak or Discord for about 5-10 seconds. After that the whole PC freezes, but it still stays on. Second time the monitor didn't lose signal and the screen froze and pc still stayed on. Can't really think what exactly it could be, because i've figured it down to mobo or ram issue.
One thing i tried after screen went black and everything froze - mashed my keyboard buttons for around 30 sec and the PC restarted by itself. As well i ran Malwarebytes and it didn't catch anything.
 
Jul 5, 2018
2
0
10
0


Desktop
CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (not OC'd)
Motherboard: ASUS MAXIMUS VII RANGER Z97 (BIOS Date: 2015)
RAM: Corsair XMS3 Dual Channel 2x4GB 1333 MHz CL9 (CMX8GX3M2A1333C9 / DDR3-1333 / PC3-10600 DDR3 SDRAM UDIMM)
GPU: AMD Radeon HD 7950/R9 280 (ASUS R9 280 DirectCU II 3GB 384bit)
HDD: Western Digital Blue 500GB/16MB (WDC WD5000AAKX-001CA0 / SATA 6Gb/s)
SSD: OCZ-VERTEX460A 120GB/32MB
PSU make and age: EVGA SuperNOVA 650GS 80+ Gold (Maximum 3 years old)
OS: Microsoft Windows 10 Education (x64) Build 17134.112 (1803/RS4)
 
thank you for providing the info I asked for not that I can see any problems but with the recent updates we have had from microsoft I have had trouble myself I just wounder it could be the same type of thing might fix it try just removing display drivers with display driver uninstaller.
Download the latest drivers for your GPU place them on your desktop get Display Driver Uninstaller from here
https://www.wagnardsoft.com/
remove everything after restarting it will probably be 640x480 not great instal your AMD/NVIDIA drivers and hopefully should fix your problem
 

ASK THE COMMUNITY

TRENDING THREADS