Question Monitor, mouse and keyboard get no power from PC

Nov 15, 2020
2
0
10
0
I've built this computer around 2 years ago and never presented any issues. Lately it's been happening that upon booting or rebooting it, the mouse, keyboard and monitor get no power from it. Monitor just goes full black, and keyboard and mouse don't get their led lights on. Weird thing is, this happens at random, sometimes I just wait it out a couple hours after this happened, try again, and it'll turn on normally Another issue I've noticed is, when this happens, there's no beep whatsoever when booting my pc, although it does turn on since the lights and the fans work just fine. Thank you in advance for any help. Another issue I forgot to list, I don't know if it's unrelated or not, when plugging my headphones I have to move the jack around a little bit otherwise they'll pick up radio static

Specs:

CPU: AMD Ryzen 3 1300x
Motherboard: Gigabyte A320M-S2H
GPU: Zotac Geforce GTX 1050ti 4GB
RAM: Ballistix 8GB DDR4 2666 Mhz
RAM: Ballistix 8GB DDR4 2666 Mhz (This one was purchased 9 months ago, built the pc initially with only 8GB)
PSU: Corsair VS450
 
Nov 15, 2020
2
0
10
0
test with a different psu?
At the moment I can't really afford getting new components for testing, sadly, and everyone I know uses a laptop which is frustrating. I did hear that nic cards can cause issues so I removed the one I had, computer turned on fine yesterday, but, today it didn't. So today I removed the 2nd stick of RAM and I'll see if it works fine without it, if not, I'll swap it around with the 1st one. Another thing I want to try is restarting or eventually replacing the CMOS battery as it's considerably cheaper than anything else I could buy.

Thank you for your response btw, and if anyone has any other suggestions on what to try I highly appreciate them. Thank you very much :)
 

ASK THE COMMUNITY

TRENDING THREADS