Question Monitor no signal

Jul 28, 2019
64
1
35
0
Help i just build a pc together for the first time and connected everything my monitor saying “no display detected” the pc is running i think okay, my monitor is a viewsonic vx2458-c-mhd 24 full hd led backlit display 144hz, i have the cables hdmi plugged from the monitor to the computer and also the when i press the on button all of the thermaltake fans are spinning rgb working, and the rgb on the cpu cooler and the 3 front fans are also spinning, when i start the machine i get 1 short beep then pause and 1 short beep? can someone help please thanks

EDIT i have no dvi d plugged in either ports as it didn’t come with one is this why mu monitor isn’t displaying an image and saying “no display detected”? Do i also need a display port plugged in?

Psu: corsair tx 550m
Graphics card: rx 580 armour mk2 oc 8gb gddr5
Processor: ryzen 2600x
Ram: ballistix 16gb 2 x 8gb ddr4 - 3200
Ssd: kingston a400 240gb, samsung 860 qvo 1tb, gigabyte ssd m.2 2280 PCIe x2 solid state drive 128gb
Motherboard: tuf b450m-plus gaming
Fans: thermaltake Riing 12 sync radiator fan RGB sync edition (3 x 120mm fan)
Front fans: using 2 x 120mm corsair carbide 275r stock fans, and a another 1 x 120mm coolmaster fan that came with different case
Pc case: corsair 275r carbide mid tower black
Fan hub: deepcool FH-04 x2, i am using one of this hub for the for 3 x 120mm thermaltake fans, and another one for the 3 x 120mm at the front
Cpu cooler: masterair ma610p
 
Last edited:
Jul 28, 2019
64
1
35
0
Pc specs please,to include the gpu being used.
Hi here my pc parts

Psu: corsair tx 550m
Graphics card: rx 580 armour mk2 oc 8gb gddr5
Processor: ryzen 2600x
Ram: ballistix 16gb 2 x 8gb ddr4 - 3200
Ssd: kingston a400 240gb, samsung 860 qvo 1tb, gigabyte ssd m.2 2280 PCIe x2 solid state drive 128gb
Motherboard: tuf b450m-plus gaming
Fans: thermaltake Riing 12 sync radiator fan RGB sync edition (3 x 120mm fan)
Front fans: using 2 x 120mm corsair carbide 275r stock fans, and a another 1 x 120mm coolmaster fan that came with different case
Pc case: corsair 275r carbide mid tower black
Fan hub: deepcool FH-04 x2, i am using one of this hub for the for 3 x 120mm thermaltake fans, and another one for the 3 x 120mm at the front
Cpu cooler: masterair ma610p
 

Fix_that_Glitch

Commendable
Mar 31, 2019
1,683
131
1,440
44
I reviewed my work and found that your motherboard should support your 2600 from any bios. So we have to look at something else. What drive has your operating system on it? And does the cpu fan spin when the computer turned on?
 
Jul 28, 2019
64
1
35
0
I can’t get a display screen, can’t see my bios version never had a diaplay so i don’t know do i need to update the bios?
I reviewed my work and found that your motherboard should support your 2600 from any bios. So we have to look at something else. What drive has your operating system on it?
no operating system installed yet, when i click the power button all the fans are spining, psu working, motherboards rgb effects are synchronizing with rainbow effects, and then i look at the monitor no display screen showing anything at all just blank screen.
 

ASK THE COMMUNITY

TRENDING THREADS