Question monitor no signal

picotnanu

Prominent
Jul 27, 2019
10
1
515
0
so ive recently build my first pc i have this problem where my monitor says "no display port signal". I've played on the pc for 2 days and it worked fine with the monitor but yesterday it disconnected and i restarted pc and it worked fine then did it again later at night, but i closed the pc because it was late and today(the next day).

The pc boots up, works fine for an hour then monitor says no signal and goes sleep mode and i cant open it back, restarting doesn't fix it.
i have the newest driver on my gpu

i tried:
checking cables
disconnect monitor power then connect
disconnect monitor display port then connect back
disconnect DP from pc and monitor
restart pc multiple times
disconnect everything then waiting a bit then connecting back
leaved everything connected and open then everything connected but pc is shut down
i also tried to connect hdmi instead of display port and doing same things
nothing worked and i dont know what do to
edit: monitor is from asus idk if it helps
 

picotnanu

Prominent
Jul 27, 2019
10
1
515
0
full system spec? include make and model of the psu
rx590 fatboy 8gb
ryzen 5 3600
mobo is gigabyte b450 gaming X
ram 2x8gb 3600Mhz viper Steel
psu corsair cv650 650W
i got 1TB hdd and
1 kingston 250gb SDD in nvme
and PC is on windoes 10 64bits
 

picotnanu

Prominent
Jul 27, 2019
10
1
515
0
full system spec? include make and model of the psu
i have also tried some thing after searching more yesterday
i tried the monitor on another pc and it worked fine so i guess its hardware related problem
i tried using both hdmi and display they dont work
i tried without the gpu
checking both ram sticks they work well
i removed the mobo battery for 30 mins
and the mobo beeps when i turn pc on so i guess its also fine
i only had the newest gpu driver and newest windows on it no other drivers installed i hope its not from that ... it worked 2 days fine
 

ASK THE COMMUNITY