Question Monitor not displaying - is my RAM incompatible with my motherboard?

Oct 26, 2021
3
0
10
0
Hi all

I recently combined a bunch of old parts from my old desktop with my younger brother's old desktop to make something my older brother can play Dota 2 on (he's currently using some laggy gaming laptop and it hurts to watch him play).

All the parts are moving and turning on fine when I press the power button, but nothing is displayed on the monitor.

Can anyone quickly check if these are compatible?

PartItem
MBAsRock AB350 Pro4
CPUAMD Ryzen 5 1600 Processor with Wraith Spire Cooler
GPUGIGABYTE GeForce GTX 760 2GB OC (rev. 2.0)
RAMKingston Kingston Hyper Gaming Memory, (PC4-19200), DDR4, HX432C16FB3K2/16, 16GB kit (2 x 8GB) 3200MHz
PSUEVGA SuperNOVA 650 G1, 80+ GOLD 650W Full Modular

I have a suspicion the RAM is the problem, being 3200 MHz

Any ideas?
 

Darkbreeze

Retired Mod
The RAM (Memory) is not a problem just because it is 3200mhz. Most any compatible RAM would simply be configured to run at the default speed of 2133mhz if the speed wasn't supported, which it isn't.

To begin with, WHICH slots do you have the memory installed in? If they are not installed in the DDR4_A2 and DDR4_B2 slots, which are the second and fourth slots away from the CPU socket, then move them to those slots and try again to POST. If they ARE in those slots, remove them, and then reinstall them, to make sure they are fully seated and locked into place at both ends. If they are in the correct slots and fully seated, try removing the graphics card and reinstalling it making sure it too is completely seated.

If it is, make sure you've connected both the 6 pin and 8 pin PCIe auxiliary power connectors to the graphics card and that you have the monitor cable plugged into the graphics cards video outputs, not the outputs from the motherboard.

If none of those is the problem, then run through the full checklist here:



If none of that works, try only one stick of RAM (Called a DIMM or memory module) in the A2 slot (Second slot over from the CPU). If that doesn't work, try the other stick in that same slot. If none of this works, then it's possible that the memory simply isn't compatible with that motherboard and trying another DDR4 DIMM in the A2 slot from a completely different manufacturer might be the only way to determine if the memory is the problem. I can tell you for certain that I've seen a lot of people who've had problems trying to run Kingston Hyper memory kits on first generation Ryzen systems, so it wouldn't be that surprising, but it won't be just because of the memory speed.
 
Reactions: tsonng
Oct 26, 2021
3
0
10
0
Hey Darkbreeze, thanks for your comprehensive reply.

I did install the processor the wrong way round, so its blocking the first memory slot. But i have tested all other 3 including the A2 slot with a single stick of RAM.

I've tried most of the full checklist, with the exception of a CMOS battery reset.

I wasn't aware about the Kingston Hyper having problems with 1st gen Ryzens. That's given me an idea to use my Corsair ram from my current desktop to see if it works.

If not I will reinstall the processor properly the right way around so I can try the first slot to see if it makes a difference. I will also try a CMOS battery reset.

Thanks a lot again.
 

Darkbreeze

Retired Mod
If you replaced the processor "the wrong way around", then all other bets are off. There would, of course, be a really good chance that in that case you had either bent the pins on the CPU or the motherboard, depending on the platform.

In this case, being an AMD platform, I'd be really inclined to say that if you had tried to run the system at ALL, with the CPU installed the wrong way, nothing is likely to work well or at all, after that. Just my two cents.
 
Oct 26, 2021
3
0
10
0
oh sorry, i didnt mean't the actual CPU. i meant the CPU fan heatsink cooler. Its just flipped 180 degrees so a bit off the end just blocks the 1st ram slot slightly. CPU is installed correctly, pins not bent etc.
 

Darkbreeze

Retired Mod
So, I'd recommend that you remove it, and install it correctly. It is not uncommon for an incorrectly installed CPU cooler, or one that is installed with one side or one corner tighter or looser than the other sides or corners, to "cock" the CPU in the socket, and cause any number of problems including random errors or just not working at all, much like with a bent pin situation. It's a place to start anyhow although initially I'm still inclined to lean towards it being incompatible memory, but it could be anything really. I'd recommend you bench it.

 

ASK THE COMMUNITY

TRENDING THREADS