• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question Monitor saying "No Signal detected !"

Jul 27, 2021
1
0
10
0
I have two BenQ Zowie XL2740 27 inch screen, and when i turn on my Monitor it says «No Signal Detected». Visually in my PC, everything seems good, but there is obviously something wrong. I recently bought a new PSU so i have fickled with some of the cables, so there may be something there that has to change. I’ve tried turning both the monitor and my PC off and everytime it just says there is no signal. I also tried to connect my PS4 to the monitor and that worked. so it is something to do with the cableing in my PC or something wrong with my new PSU or GPU.
 
I have two BenQ Zowie XL2740 27 inch screen, and when i turn on my Monitor it says «No Signal Detected». Visually in my PC, everything seems good, but there is obviously something wrong. I recently bought a new PSU so i have fickled with some of the cables, so there may be something there that has to change. I’ve tried turning both the monitor and my PC off and everytime it just says there is no signal. I also tried to connect my PS4 to the monitor and that worked. so it is something to do with the cableing in my PC or something wrong with my new PSU or GPU.
It's time to divulge your PC's parts.
 

Jacob 51

Proper
Dec 31, 2020
459
19
185
0
I have two BenQ Zowie XL2740 27 inch screen, and when i turn on my Monitor it says «No Signal Detected». Visually in my PC, everything seems good, but there is obviously something wrong. I recently bought a new PSU so i have fickled with some of the cables, so there may be something there that has to change. I’ve tried turning both the monitor and my PC off and everytime it just says there is no signal. I also tried to connect my PS4 to the monitor and that worked. so it is something to do with the cableing in my PC or something wrong with my new PSU or GPU.
Did you connect the display cable to your new GPU? You have to plug it in the GPU and NOT on the motherboard.
 

ASK THE COMMUNITY