Question Monitor suddenly stopped working, says no signal. What should I do to fix this?

Prizmonix

Honorable
Sep 22, 2013
43
1
10,535
0
So recently I made this build:
https://uk.pcpartpicker.com/list/pkCVgJ

Everything worked perfectly for two weeks. Then suddenly when I was playing the monitor turned off. Now when I try to boot sometimes the keyboard and mouse will not turn on (can tell by the rgb lights) but all the time the monitor will say no signal.

I didn't upgrade my gpu because I'm still saving for a good one so I decided to use my old one but all other components are new, could that be it?

I will appreciate any help. I really want to use my computer again.
 
So recently I made this build:
https://uk.pcpartpicker.com/list/pkCVgJ

Everything worked perfectly for two weeks. Then suddenly when I was playing the monitor turned off. Now when I try to boot sometimes the keyboard and mouse will not turn on (can tell by the rgb lights) but all the time the monitor will say no signal.

I didn't upgrade my gpu because I'm still saving for a good one so I decided to use my old one but all other components are new, could that be it?

I will appreciate any help. I really want to use my computer again.
Verify your power cables to the GPU are intact. If they are and still no boot try onboard graphics. Your CPU has Intel graphics. Hook the monitor to the motherboard hdmi or whatever connection you're using and see if it boots with a working display. If it does then it's possible the GPU may be toast. You have a pretty good power supply so I would not immediately suspect it, but it's still a slight possibility.
 

Prizmonix

Honorable
Sep 22, 2013
43
1
10,535
0
Verify your power cables to the GPU are intact. If they are and still no boot try onboard graphics. Your CPU has Intel graphics. Hook the monitor to the motherboard hdmi or whatever connection you're using and see if it boots with a working display. If it does then it's possible the GPU may be toast. You have a pretty good power supply so I would not immediately suspect it, but it's still a slight possibility.
Hey thanks for responding. I just checked my cables and they seemed to be okay. I also plugged my cables into the motherboard instead of the GPU and still nothing so I'm really confused. The monitor still works with my old Xbox 360 which I just checked now. No idea what's going on but appreciate the advice.
 

ASK THE COMMUNITY

TRENDING THREADS