Question Monitor won't display anything?

Mar 7, 2022
8
0
10
0
Motherboard: gigabyte aorus z590 master
Cpu : Intel i3 10400F
Vga: gigabyte windforce Gv-n680oc-2gd
Psu: Corsiar 750cx
Ram: Corsiar rgb pro4x8gb
I was told by gigabyte that the cpu I have installed atm doesn't not support video from the on board display port plug I was also told that my grx card is to old and that I need to upgrade it to continue trying to fix the problem. And here is some more information I had the gfx card and cpu up and running fine but I changed something in the bios and after I save and restarted the screen wouldn't light up.. The desktop would fans lights etc.. But no display I tried reseting the bios IE removing the cmos battery also pressing the cmos reset button and hitting the jumper but still no response from the computer other than the initial power up and no display.. Any help would be so greatly appreciated.
 

Darkbreeze

Retired Mod
Any Intel CPU model that ends in "F" lacks having integrated graphics onboard.

That graphics card "should" most likely still work in that board if the card is good and the BIOS has legacy options such as CSM (Compatibility support module) enabled but if you can't get into the BIOS with this graphics card then you may need to borrow or purchase a different card in order to do that. In all honesty, if this is for gaming at all, that GPU is too old and weak to be much good anymore for much of anything other than general use and watching video. You'll have a hard time with it playing anything substantial unless you're willing to turn the majority of settings way down.

Do you know for certain that the graphics card works? You've checked it in another system, recently, to verify? Then what you "changed" in the BIOS likely had to do with CSM or legacy support.

With the graphics card installed, try this, but if it fails to work you will probably need another card to fix the issue.

BIOS Hard Reset procedure

Power off the unit, switch the PSU off and unplug the PSU cord from either the wall or the power supply.

Remove the motherboard CMOS battery for about three to five minutes. In some cases it may be necessary to remove the graphics card to access the CMOS battery.

During that five minutes while the CMOS battery is out of the motherboard, press the power button on the case, continuously, for 15-30 seconds, in order to deplete any residual charge that might be present in the CMOS circuit. After the five minutes is up, reinstall the CMOS battery making sure to insert it with the correct side up just as it came out.

If you had to remove the graphics card you can now reinstall it, but remember to reconnect your power cables if there were any attached to it as well as your display cable.

Now, plug the power supply cable back in, switch the PSU back on and power up the system. It should display the POST screen and the options to enter CMOS/BIOS setup. Enter the bios setup program and reconfigure the boot settings for either the Windows boot manager or for legacy systems, the drive your OS is installed on if necessary.

Save settings and exit. If the system will POST and boot then you can move forward from there including going back into the bios and configuring any other custom settings you may need to configure such as Memory XMP, A-XMP or D.O.C.P profile settings, custom fan profile settings or other specific settings you may have previously had configured that were wiped out by resetting the CMOS.

In some cases it may be necessary when you go into the BIOS after a reset, to load the Optimal default or Default values and then save settings, to actually get the hardware tables to reset in the boot manager.

It is probably also worth mentioning that for anything that might require an attempt to DO a hard reset in the first place, IF the problem is related to a lack of video signal, it is a GOOD IDEA to try a different type of display as many systems will not work properly initially for some reason with displayport configurations. It is worth trying HDMI if you are having no display or lack of visual ability to enter the BIOS, or no signal messages.

Trying a different monitor as well, if possible, is also a good idea if there is a lack of display. It happens.
 
Last edited:

ASK THE COMMUNITY