Question Monitor won't power on and mouse light flickering?

olly29

Honorable
Oct 1, 2015
76
0
10,630
0
Hey guys, so recently I've started to get a bit of input lag on my system. Small things like mouse cursor ghosting and graphical stuttering when playing games which feels weird because they are not highly demanding games for my setup.
As of a few days ago my monitor will occasionally not power on when I boot the pc and my mouse ball light which is usually a still light will be flickering. I will have to force reboot the pc for it to work again. Does anyone know anything about this?
(I had a period where I got some what frequent brown outs, could this have impacted my setup?)

cpu: AMD Ryzen 7 2700X 3.7ghz

gpu: gtx 1070

mobo: gigabyte b450 gaming X

seasonic focus plus 650w gold standard

monitor: acer predator 144hz 24in
 

Lutfij

Titan
Moderator
It'd be a good idea to mention the games you tax the system with, without mentioning an etc. at the end of the sentence. You might want to see if the mouse exhibits the same issue on a donor system/laptop. What BIOS version are you currently working with? What OS version are you on for your platform?

Age of the Seasonic unit in your build? Can you use HWMonitor to show you what the temps are while the issue crops up?
 

olly29

Honorable
Oct 1, 2015
76
0
10,630
0
It'd be a good idea to mention the games you tax the system with, without mentioning an etc. at the end of the sentence. You might want to see if the mouse exhibits the same issue on a donor system/laptop. What BIOS version are you currently working with? What OS version are you on for your platform?

Age of the Seasonic unit in your build? Can you use HWMonitor to show you what the temps are while the issue crops up?
I play both CSGO and Dota 2. I run both with quite low settings as I'm more concerned with the gameplay rather than graphics and I still get small graphical glitches in both games on low settings. The mouse also feels like it moves jagged in menu screens and has slight ghosting behind it. I've tested the mouse on another pc and a laptop and it works fine.
As for the OS i'm using windows 10 home.
My BIOS version is American Megatrends Inc F50, 27/11/2019 (and SMBIOS version is 3.2 if that is needed).
I've used HWMonitor to check temps and they are all fine.
The PSU exact model is the Seasonic X-650 80 Plus Gold 650W which I got probably about 5 years ago.
Thanks
 

ASK THE COMMUNITY

TRENDING THREADS