Solved! Monitors not working on Displayport

Mar 8, 2019
2
0
10
0
Hello there,

I currently bought a second monitor for my PC. (BENQ GL2580)

My older Monitor is connected to my GTX 1080 TI via HDMI and works just fine. However, the 1080 only has one HDMI port, the other three are Displayports.
Since the BENQ I bought only has HDMI as well I bought an additional adapter from DP to HDMI.

I get no signal from the Monitor plugged into the DP with the adapter. I tried both Monitors, the new one and the old. The one that's plugged in via HDMI works just fine, the one that's plugged in via DP gets "No signal."

So I thought I might got a faulty adapter. And just to test things out, I have enabled the use of my onboard gpu. And to my surprise, the onboard DP works just fine. But since I have been told that it's not healthy to use two different gpus, I want to avoid that situation.

And since my HDMI port on the 1080 works just fine, it's kinda hard to believe that all three remaining DP are faulty. I have checked my drivers and everything is up to date. Also tried cutting power from the monitor for several minutes because that apparently did the trick for some people on the internet - not for me however.

Does anyone have any ideas what might be possibly the issue here?
 
Mar 8, 2019
2
0
10
0
There is no problem using the iGPU, none at all. (there was a problem using both nvidia and amd gpu's at one time).
Even when using another GPU like the 1080? Most results I got mentioned that it's not the best ideas to pull resources from two separate cards.
It could be that your mobo is an older version of DP compared to the GPU?
Is there a way to check that? Both my GPU and my mobo are fairly new. The mobo I have is a MSI Z370 Gaming M5 Mainboard
 

13thmonkey

Titan
Moderator
Even when using another GPU like the 1080? Most results I got mentioned that it's not the best ideas to pull resources from two separate cards.


Is there a way to check that? Both my GPU and my mobo are fairly new. The mobo I have is a MSI Z370 Gaming M5 Mainboard
I've been doing it for the last 4 years iGPU + GTX 970, and previous to that GT210 and GTX 470/580 for years.
 

ASK THE COMMUNITY

TRENDING THREADS