Question Monitors randomly lose signal while gaming

Cjparra

Prominent
Nov 9, 2020
7
1
515
0
Hey everyone, I was hoping I could get some help with an issue I’ve been having. Sometimes when I am gaming my monitors will randomly lose signal and I am forced to restart my pc to get it back. This issue only happens when I’m playing a game and it is completely random, sometimes I’ll go days without it happening and other times it’ll happen multiple times in 1 day. I’ve checked the event logs and they didn’t help me very much, all my drivers are up to date, and it isn’t an overheating problem. Recently I even upgraded my power supply from a 650 to a 750 watt which seemed to have solved the problem for over a month but just yesterday I was playing the new forza for a little bit and it happened again. At this point I am getting extremely frustrated.
I would appreciate any input you guys may have! I’ll list the specs below if anyone is curious as well.

Ryzen 5 3600
Evga 2070 Super XC Ultra
Asus B550-F gaming (WiFi)
16gb Corsair vengeance pro ram
1TB M.2 nvme
2tb Hdd
Nzxt z73 AIO
Corsair Rm(2019) 750W psu
Lian li 011 case
 

avg9956

Respectable
Apr 7, 2019
404
94
1,890
49
What monitor do you use? How old is your monitor?
My wild guess is try refitting your monitor cables (HDMI/DP or what have you that you use to connect from your monitor to your GPU) since you may have loosened them unknowingly (It happens). If that doesn't fix it, try changing them.
 

Cjparra

Prominent
Nov 9, 2020
7
1
515
0
What monitor do you use? How old is your monitor?
My wild guess is try refitting your monitor cables (HDMI/DP or what have you that you use to connect from your monitor to your GPU) since you may have loosened them unknowingly (It happens). If that doesn't fix it, try changing them.
I have two lg27gl850 monitors one which I bought last month and the other is less than a year old. And I actually already bought a new pair of DisplayPort cables to try to fix the problem and it didn’t work.
 

avg9956

Respectable
Apr 7, 2019
404
94
1,890
49
Found a thread with your exact same monitor's issues. Also has the same GPU with you (RTX 2070)
No definitive resolution but I find one of them solved it by rolling back to a previous Nvidia driver version 472.12

472.12-desktop-win10-win11-64bit-international-whql) and after 5 mins of usage 0 black bars, previously i had around 1-2/min.
Or try disabling G-sync and Smart energy saving
Worse case scenario, it might be your GPU is dying too, though I'd hate to say it - its a narrow possibility.
 
Last edited:

Cjparra

Prominent
Nov 9, 2020
7
1
515
0
Found a thread with your exact same monitor's issues. Also has the same GPU with you (RTX 2070)
No definitive resolution but I find one of them solved it by rolling back to a previous Nvidia driver version 472.12



Or try disabling G-sync and Smart energy saving
Worse case scenario, it might be your GPU is dying too, though I'd hate to say it - its a narrow possibility.
Ya I was afraid it might be my graphics card because I only built this pc last year and have already had to replace it once. I think that could be the gpu though because the rgb on it has been flickering out as well so that could be a sign. I’ll try those other possible solution when I get home. Thank you for your help!
 
Reactions: avg9956

Cjparra

Prominent
Nov 9, 2020
7
1
515
0
Ya I was afraid it might be my graphics card because I only built this pc last year and have already had to replace it once. I think that could be the gpu though because the rgb on it has been flickering out as well so that could be a sign. I’ll try those other possible solution when I get home. Thank you for your help!
Ya I was afraid it might be my graphics card because I only built this pc last year and have already had to replace it once. I think that could be the gpu though because the rgb on it has been flickering out as well so that could be a sign. I’ll try those other possible solution when I get home. Thank you for your help!
Now that I’m looking at it I’m not sure I’m having the same problem that is mentioned in that other thread because my monitors completely lose signal it’s not just a flickering.
 

ASK THE COMMUNITY

TRENDING THREADS