[SOLVED] Monitors Turn Brown/Grey Then Lose Signal, Keyboard And Mouse Disconnect Put PC Stays Running.

Dec 14, 2019
2
0
10
0
Hi Guys, I recently built my own gaming pc and it works perfectly find browsing the internet watching YouTube Ect...
I Can Run Rocket League on steam Perfectly Fine.
But when i try to play either Rainbow Six Siege, Fortnite Or Apex Legends I can play around 30Min To 1 Hour (Some Times Even Less)
Before one of my monitors turns brown and the other turns grey, makes a static noise in my headset and then loses signal to both of the monitors and my keyboard and mouse.
The only thing that i can do at this point is hold the power button down to restart the computer and from then it works fine until i play games.

The fans keep spinning inside the case and the LED lights stay on (so i'm thinking that it couldn't be a mother board problem)

I have read all the forums here that have almost the exact same problem as i, but I've basically tried all the "Best Solutions" and none of them have seemed to fix the problem.
Here is a short list of most of the things that i have done to try to fix this.

I Have,
Updated the drivers for almost everything i have and removing the old,

Updated my Bios to the latest version,

Made sure the temperatures are below or on par with whats recommended,

Changed Monitors, The Display ports, I've tried Hdmi, VGA, And Dvi,

Opened the side case and made sure everything is okay and plugged i well,

I have changed PCIe cable that was plugged into the GPU just in case the one that i was using was faulty.

I Have 1 8GB Ram stick right now and it was plugged into slot 1, i changed it to slot 2 and it still didn't work, (i changed it back to slot 1 since it didn't help)

The list goes on a little longer but i don't want to make this too long.

Here are my current specs,

CPU/ AMD Ryzen 5 2600x Processor.

Motherboard/ ASRock B450M-HDV R4.0.

RAM/ DDR4 8GB HyperX Kingston Single Stick.

Graphics Card/ Radeon RX 580 Saphire Pulse 4gb

Power Supply/ Corsair 650w

Any suggestions would massively help since it took me 6 months to buy these parts and i don't really want this pc and my money to have gone to waste.

Thanks To Anyone That Can Help
Ceytn.
 
Last edited:
Dec 28, 2019
3
0
10
1
Hi Guys, I recently built my own gaming pc and it works perfectly find browsing the internet watching YouTube Ect...
I Can Run Rocket League on steam Perfectly Fine.
But when i try to play either Rainbow Six Siege, Fortnite Or Apex Legends I can play around 30Min To 1 Hour (Some Times Even Less)
Before one of my monitors turns brown and the other turns grey, makes a static noise in my headset and then loses signal to both of the monitors and my keyboard and mouse.
The only thing that i can do at this point is hold the power button down to restart the computer and from then it works fine until i play games.

The fans keep spinning inside the case and the LED lights stay on (so i'm thinking that it couldn't be a mother board problem)

I have read all the forums here that have almost the exact same problem as i, but I've basically tried all the "Best Solutions" and none of them have seemed to fix the problem.
Here is a short list of most of the things that i have done to try to fix this.

I Have,
Updated the drivers for almost everything i have and removing the old,

Updated my Bios to the latest version,

Made sure the temperatures are below or on par with whats recommended,

Changed Monitors, The Display ports, I've tried Hdmi, VGA, And Dvi,

Opened the side case and made sure everything is okay and plugged i well,

I have changed PCIe cable that was plugged into the GPU just in case the one that i was using was faulty.

I Have 1 8GB Ram stick right now and it was plugged into slot 1, i changed it to slot 2 and it still didn't work, (i changed it back to slot 1 since it didn't help)

The list goes on a little longer but i don't want to make this too long.

Here are my current specs,

CPU/ AMD Ryzen 5 2600x Processor.

Motherboard/ ASRock B450M-HDV R4.0.

RAM/ DDR4 8GB HyperX Kingston Single Stick.

Graphics Card/ Radeon RX 580 Saphire Pulse 4gb

Power Supply/ Corsair 650w

Any suggestions would massively help since it took me 6 months to buy these parts and i don't really want this pc and my money to have gone to waste.

Thanks To Anyone That Can Help
Ceytn.
OK I got some answers from the guarantee company
If you checked your softwares and nothing changed
There is 4 main possibilities here
1 your psu is damaged
2 your GPU
3 your power cables are damaged
Or
4 your memory or motherboard but this two
But the 4th has a very low chance
And there is some others like ground problems in house power cables
Or electricity leakage to your case and blah blah blah the list goes on for ever so if you can get your pc to a guarantee company
Also sry if my English isn't good enough I'm from Iran 🙃 wish you luck
 
Dec 28, 2019
3
0
10
1
Hi Guys, I recently built my own gaming pc and it works perfectly find browsing the internet watching YouTube Ect...
I Can Run Rocket League on steam Perfectly Fine.
But when i try to play either Rainbow Six Siege, Fortnite Or Apex Legends I can play around 30Min To 1 Hour (Some Times Even Less)
Before one of my monitors turns brown and the other turns grey, makes a static noise in my headset and then loses signal to both of the monitors and my keyboard and mouse.
The only thing that i can do at this point is hold the power button down to restart the computer and from then it works fine until i play games.

The fans keep spinning inside the case and the LED lights stay on (so i'm thinking that it couldn't be a mother board problem)

I have read all the forums here that have almost the exact same problem as i, but I've basically tried all the "Best Solutions" and none of them have seemed to fix the problem.
Here is a short list of most of the things that i have done to try to fix this.

I Have,
Updated the drivers for almost everything i have and removing the old,

Updated my Bios to the latest version,

Made sure the temperatures are below or on par with whats recommended,

Changed Monitors, The Display ports, I've tried Hdmi, VGA, And Dvi,

Opened the side case and made sure everything is okay and plugged i well,

I have changed PCIe cable that was plugged into the GPU just in case the one that i was using was faulty.

I Have 1 8GB Ram stick right now and it was plugged into slot 1, i changed it to slot 2 and it still didn't work, (i changed it back to slot 1 since it didn't help)

The list goes on a little longer but i don't want to make this too long.

Here are my current specs,

CPU/ AMD Ryzen 5 2600x Processor.

Motherboard/ ASRock B450M-HDV R4.0.

RAM/ DDR4 8GB HyperX Kingston Single Stick.

Graphics Card/ Radeon RX 580 Saphire Pulse 4gb

Power Supply/ Corsair 650w

Any suggestions would massively help since it took me 6 months to buy these parts and i don't really want this pc and my money to have gone to waste.

Thanks To Anyone That Can Help
Ceytn.
I have the same problem if you found a solution tell me I'm sending back my pc to the company 😑
 
Dec 28, 2019
3
0
10
1
Hi Guys, I recently built my own gaming pc and it works perfectly find browsing the internet watching YouTube Ect...
I Can Run Rocket League on steam Perfectly Fine.
But when i try to play either Rainbow Six Siege, Fortnite Or Apex Legends I can play around 30Min To 1 Hour (Some Times Even Less)
Before one of my monitors turns brown and the other turns grey, makes a static noise in my headset and then loses signal to both of the monitors and my keyboard and mouse.
The only thing that i can do at this point is hold the power button down to restart the computer and from then it works fine until i play games.

The fans keep spinning inside the case and the LED lights stay on (so i'm thinking that it couldn't be a mother board problem)

I have read all the forums here that have almost the exact same problem as i, but I've basically tried all the "Best Solutions" and none of them have seemed to fix the problem.
Here is a short list of most of the things that i have done to try to fix this.

I Have,
Updated the drivers for almost everything i have and removing the old,

Updated my Bios to the latest version,

Made sure the temperatures are below or on par with whats recommended,

Changed Monitors, The Display ports, I've tried Hdmi, VGA, And Dvi,

Opened the side case and made sure everything is okay and plugged i well,

I have changed PCIe cable that was plugged into the GPU just in case the one that i was using was faulty.

I Have 1 8GB Ram stick right now and it was plugged into slot 1, i changed it to slot 2 and it still didn't work, (i changed it back to slot 1 since it didn't help)

The list goes on a little longer but i don't want to make this too long.

Here are my current specs,

CPU/ AMD Ryzen 5 2600x Processor.

Motherboard/ ASRock B450M-HDV R4.0.

RAM/ DDR4 8GB HyperX Kingston Single Stick.

Graphics Card/ Radeon RX 580 Saphire Pulse 4gb

Power Supply/ Corsair 650w

Any suggestions would massively help since it took me 6 months to buy these parts and i don't really want this pc and my money to have gone to waste.

Thanks To Anyone That Can Help
Ceytn.
OK I got some answers from the guarantee company
If you checked your softwares and nothing changed
There is 4 main possibilities here
1 your psu is damaged
2 your GPU
3 your power cables are damaged
Or
4 your memory or motherboard but this two
But the 4th has a very low chance
And there is some others like ground problems in house power cables
Or electricity leakage to your case and blah blah blah the list goes on for ever so if you can get your pc to a guarantee company
Also sry if my English isn't good enough I'm from Iran 🙃 wish you luck
 

ASK THE COMMUNITY

TRENDING THREADS