Question Monitors turned off suddenly..

TheGreekMan2

Reputable
Nov 16, 2015
17
0
4,510
0
Hi, i know similar questions have been asked on here but I am trying to determine the cause of my issues as they seem to be slightly different.

My computer was working fine two days ago and then very suddenly the screens went to cannot display/ no source signal.

There are a number of solutions/ideas I have already tried. I have already removed RAM and tried one stick at a time, that did not work. I tried changing the GPU and the GPU slots, that did not work. I know that the PSU is not the issue because the computer starts up normally and I can login and hear it and everything. The monitors and cables also both work fine. (TLDR, not monitors, not cables, not GPU, not RAM). PS I do not have onboard graphics for my mobo so I cannot get anything open. Computer also can stay on without losing power np.

At this point I am thinking the issue lie with the CPU or mobo, but have no idea which could be responsible.. Any help is appreciated.
 

TheGreekMan2

Reputable
Nov 16, 2015
17
0
4,510
0
psu could be not giving enough power to the gpu

full system spec? include make and model of the psu
GPU in right now is RX 270 4GB
CPU in there is an old AMD 8350 I believe.
PSU EVA 750G Gold
MOBO Gigabyte 970 AMD SLI
RAM Corsair and G-Series 4 x 4 gb 1600mhz DDR3
 
Last edited:

TheGreekMan2

Reputable
Nov 16, 2015
17
0
4,510
0
GPU in right now is RX 270 4GB
CPU in there is an old AMD 8350 I believe.
PSU EVA 750G
MOBO Gigabyte 970 AMD SLI
RAM Corsair and G-Series 4 x 4 gb 1600mhz DDR3
Theres an additional GPU power slot on the PSU (its modular) should I try swapping to that? Or would the PSU not provide enough regardless of the slot?
 

ASK THE COMMUNITY

TRENDING THREADS