Question Motherboard and psu

Nov 9, 2020
3
0
10
0
My friend was installing a pcie WiFi adapter into my computer whilst it was running (rookie mistake I know) and it hit the gpu and sparked gpu doesn’t work now it at least I think, I’ve bought a new motherboard and a psu and still the pc isn’t turning on. Both my psu worked with paper clip test. Neither of my motherboards LED will turn on but my case one will. Cannot turn it in any fashion none of the fans spin either.

Rx580 sapphire nitro+
Ryzen 1600
8gb ripjaw ddr4
Amd b450
 
My friend was installing a pcie WiFi adapter into my computer whilst it was running (rookie mistake I know) and it hit the gpu and sparked gpu doesn’t work now it at least I think, I’ve bought a new motherboard and a psu and still the pc isn’t turning on. Both my psu worked with paper clip test. Neither of my motherboards LED will turn on but my case one will. Cannot turn it in any fashion none of the fans spin either.

Rx580 sapphire nitro+
Ryzen 1600
8gb ripjaw ddr4
Amd b450
Paper clip test at best shows that PSU fan is working so it's not real test for it. It's most likely that your MB got damaged too. Only way is to test GPU and MB separately.
 
Nov 9, 2020
3
0
10
0
Paper clip test at best shows that PSU fan is working so it's not real test for it. It's most likely that your MB got damaged too. Only way is to test GPU and MB separately.
Yeah I’ve just bought a new mother board so I’ve ruled that out (this is after the whole thing happened) and a new psu today and nothing works still
 
Nov 9, 2020
3
0
10
0
What about GPU ? Did you try without it ? You won't get any picture from MB because 1600 doesn't have an IGPU but it should at least light up or fans would turn.
Tried without gpu and nothing no LED or fans boot up. Graphics card when plugs in doesn’t get fans going either
 

ASK THE COMMUNITY

TRENDING THREADS