Question Motherboard BIOS black screen ?

Aug 11, 2022
Basically I am running a msi z390-a-pro motherboard and cant view the bios or bios logo once I set my bios to Uefi mode. Now it works in legacy mode but windows 11 needs uefi mode. I tried taking out cmos battery, then I can load to bios but it's set back to legacy. I tried changing the GPU from an AMD Radeon RX 590 to an Nvidia 2060 . I could load into the bios uefi mode for a couple of days but then it broke again. I can't keep changing my gpus back and forth. What's causing this problem?

My processor is i5-9400f and using Corsair ddr4 3000 mhz vengeance Ram. Please any help is appreciated.


Update your post to include full system hardware specs and OS information.

This motherboard?

Verify that I found the applicable User Manual.

Refer to the User manual to double check all current connections and configurations.

For example with memory:

"Always insert memory modules in the DIMMA2 slot first "
( Source: Physically numbered Page 26.)

Clear CMOS per the instructions provided on physically numbered Page 35.

Failing that, try replacing the CMOS battery with a new fresh battery as a matter of elimination.

While the system is powered down, unplugged, and the case is open:

Clean out dust and debris.

Verify by sight and feel that all cards, connections, RAM, jumpers, and case panel connections are al fully and firmly in place.

Use a bright flashlight to inspect for any signs of damage.

Hopefully just some configuration error of omission or commission.