Question Motherboard detects my storage, but will not boot from it. Should I Act on Motherboard Warranty?

Jul 20, 2019
3
0
10
0
Specs & Info:
Motherboard - ASUS Prime Z390 - A
CPU - i5 9400 f
RAM - Vengeance RGB Pro (32gb)
GPU - 1050 ti
PSU - 700 Watt (Thermaltake)
M.2 - (normal boot drive) Crucial 250 gb
HDD - WD Black 1tb
OS - Windows 10 Pro

The Issue: I built this PC a couple of days ago and until now it's worked perfectly. After a normal restart, it started booting automatically into the UEFI, the boot selector stating that "The system cannot find any bootable devices". The weird part is that other parts of the UEFI have no problem detecting my drives.

What I've tried: Simple on and off restart. Turn off and clear power from the system. Downloading ASUS Bios recovery software (although nothing happened when I tried to use the USB stick in which it was downloaded).

So back to the question in the thread name. Should I try to act on the warranty? Any suggestions would be very appreciated. Also, it's my first time posting a thread like this. So if I missed any information, I apologize and I'll add it as soon as possible.
 

ASK THE COMMUNITY

TRENDING THREADS