Question Motherboard does not POST with DUAL CPU


Dec 9, 2017
I have the Supermicro X10-DAC motherboard with dual CPU sockets. I did some initial testing on the motherboard outside the case on a anti-static sheet workbench. Both CPUs were working fine and everything was good.

Decided to install into a case, so I shut it down, installed in it but then it wouldn't post or beep like it used to while coming up.

Thinking there was a bad connection, returned the motherboard back on the bench. Same thing, it's dead.

Thought maybe one of my CPUs stopped working so I removed CPU2 from socket 2 keeping CPU1 in socket 1, and VIOLA it boots.

Removed CPU1 from socket1 now knowing both CPU1 and socket1 work fine and put CPU2 in socket 1, again successful boot.

Ok so now I can determine CPU1 and CPU2 are working fine.

Tried putting just CPU1 in socket2, nothing

Put CPU2 in socket2, nothing

Does that mean my socket2 went bad while it was being moved into the case?

P.S I also tried swapping the RAM modules in case it was a RAM issue. No luck