Question Motherboard failing to find hard drive

Jan 10, 2021
17
0
10
0
HI,
I've been having this problem for a couple of weeks now. I have a MSI B450-A Pro Max with a Samsung 500GB 860 Evo 2.5" and a Seagate 2TB 3.5" Internal HDD, 7200RPM. I run Ubuntu 20.04 and it needs to HDD to boot, it contains the /home partition, but recently has been failing to mount the HDD drive. Boot logs just contain "Device in Error I/O error" over and over again. The computer boots about 50% of the time and fails the other 50%. I have ran multiple extended S.M.A.R.T tests on the HDD and it all comes back clean. Refer to image below:
HDD S.M.A.R.T Test

I have now realized that the motherboard is failing to find the drive. If I boot into the BIOS and select the "Board Explorer" (which shows everything which is connected to the board), my SSD will show connected to the SATA 2 port but will not display the HDD. I have tried replacing the SATA cable to the HDD and trying a different header on the board. I even swapped the two drives on the board that way the HDD is plugged into a SATA port I know is working, as the SSD was plugged into it. The system and drive itself is only just over a year old. It all works well when I can get it to boot but sometimes it just fails over and over even if I reboot it multiple times.
Any ideas? Let me know if I can provide any more information to help

Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS