Motherboard issue? PC crash/reboots randomly on connecting EVGA CLC cooler for CPU to the USB 2.0 header on MBD

rahilpathan56

Prominent
Jul 6, 2018
12
0
510
0
specs: GIGABYTE Gaming 7 z370 with Intel i7-8700K
cooler: EVGA CLC 120 Liquid / Water CPU Cooler, RGB LED Cooling.
PSU: EVGA G3 1000W

EDIT: I got the replacement motherboard.
Still the issue is same.
 

Lutfij

Titan
Moderator
Try loosening the backplate/mounting a little and see if the issue persists. When you say randomly on connecting the AIO to USB2.0 port, is the system running while you're doing that?

See if you're on the latest BIOS update for your motherboard and then verify that you're on the latest chipset drivers.
 

rahilpathan56

Prominent
Jul 6, 2018
12
0
510
0


yes the system is running when that happens.It is mostly when I try to open a game or higher cpu load than normal. it reboots an keeps doing that until I turn off the power. I tried the Latest bios from Mfg website that didn't help.
Drivers are installed from the cd which came with the motherboard.

I am using the same SSD from my laptop with i7 6700HQ. Is it alright or should I do a clean windows install?
 
Oct 30, 2018
9
0
20
1
Honestly never use the cd drivers that come with motherboard or any part i highly reccomend downloading it from the manufacturer's website because it will have new fixes and everything for newer operating systems
 

rahilpathan56

Prominent
Jul 6, 2018
12
0
510
0
It was faulty EVGA CLC 120 Cooler, it was drawing more power I guess and motherboard was not allowing that.
I switched to Corsair 240mm liquid cooling system and voilla no issues.
 

ASK THE COMMUNITY