Question Motherboard issues please help!!

THEmaged

Commendable
Apr 22, 2017
33
0
1,530
0
Hello everyone I recently upgraded my motherboard to an Asus Rog strix z390-i a very good itx board which I paired up with an i5 9400f when I first built it, it started up perfectly no issues there I updated all the drivers immediately chipset, BIOS, audio, all good then a few days later (today) I was playing a game this morning then I suddenly had to leave so I just pressed the off button on the case (while in game don't know if that matters) then I come back and the system boots up perfectly except for the fact that the monitor doesn't show anything and I saw that the motherboard was turning on these LEDs Red Orange then white in that order then it just stays white and the computer doesn't do anything after that it just stays on fans working cpu fan works fine but the monitor doesn't show anything. Please help if you have any idea on her to fix this problem.


My specs:
Cpu: i59400f
Cooler: Noctua NH-U12s
GPU: Rx 5700 (red dragon)
Ram: corsair 16 GB ddr4 2666
 

THEmaged

Commendable
Apr 22, 2017
33
0
1,530
0
make and model of the psu
So my friend told me it was a VGA issue and I needed to reset my mobo and I have located the jumper pins on the mobo but how do I go about clearing the rtc ram correctly? Do i turn on the computer and then short circuit them?
 

THEmaged

Commendable
Apr 22, 2017
33
0
1,530
0
So my friend told me it was a VGA issue and I needed to reset my mobo and I have located the jumper pins on the mobo but how do I go about clearing the rtc ram correctly? Do i turn on the computer and then short circuit them?
Also it's an EVGA 500 watt PSU I know it's a little bit underpowered for my components but I'll be buying a new one soon
 

ASK THE COMMUNITY

TRENDING THREADS