Question Motherboard LEDs turn on but system won't boot ?

Jan 7, 2023

I'm having some trouble with my PC. It's been a while since I turned it on and I've moved twice in that time. None of the hardware has changed since I last used it, so I'm quite confused as to why it's not POSTing now.

Here's what's happening:
When connected to power, the LEDs on my X570 plus motherboard light up, but when I try to press the power button on my case or short the power sw pins manually nothing happens.

Here's what I've tried:
I've followed the "PC won't boot" Troubleshooting thread.
I cleared the CMOS RTC RAM data and replaced the battery entirely.
I took the motherboard out of the case, leaving only the CPU, its fan+heatsink, one stick of ram (down from two, installed in the correct slow), and the 24-pin & 8-pin power connectors from the PSU connected to the mobo.
I've tried reseating various connectors and cables.

Despite this, the problem persists. the LEDs light up whenever power is connected, but I can't get the system to do anything else.
I don't have any spare components to test this with so I'm at a loss of what to do. I've contacted ASUS support but haven't received a reply yet.

I have an ASUS TUF X570 Plus (wifi) motherboard and a Ryzen 9 3950X. I was using two sticks of Vengeance LPX DDR4 16gb RAM, but have removed one for testing.

Just to reiterate, I've not changed anything in this system between now and the last time I used it (when it worked fine).

Happy to provide any more details if needed.


Welcome to the forums, newcomer!

Here's what you could try and do. According to the motherboard manual;
your board has what's dubbed ASUS CrashFree BIOS 3, so you can recover your BIOS in case it went sideways(corrupt). Follow along what's stated in page 3-22, chapter 3, section 3.11.3. As for your sticks of ram, they were in slots A2 and B2, correct? With one stick, then A2, correct?

Can you please list the specs to your build like so:

As for your moves, were they within the same country?
Jan 7, 2023
Hi! Thanks for the welcome.

I didn't know about the recover feature, fingers crossed! I'll give it a try and update here in a bit.
The moves were in the same country. I wasn't the most careful I could have been with the desktop, but I did wrap it in a very thick blanket and had it in the back seat with a seatbelt across it.

As for my specs:
CPU: Ryzen 9 3950X
Motherboard: ASUS TUF X570 Plus (wifi)
Ram: Corsair Vengeance LPX 2x16GB
SSD/HDD: 2x Samsung 960 evo Sata 250GB SSDs
GPU: MSI 2080ti
PSU: Be Quiet! Dark Power Pro 650W
Chassis: NZXT S340
OS: Windows 10
Monitor: ASUS PG27UQ
Jan 7, 2023
Ok so I followed the instructions, made a USB with the recovery BIOS but couldn't get any further. I found this video from ASUS Support on how to recover the BIOS with this method and it shows that a message pops up after POSTing. This doesn't happen for me because the system doesn't POST at all.

Also in regard to your earlier message about the RAM, I've tested the system with two sticks in A2&B2, and with one stick in A2.

At this point I'm thinking it's likely that the CPU pins have bent in the moves. Any suggestions on how to check for that? I'm thinking taking the heatsink off and having a look at the CPU.