Question Motherboard light turns on, but PC won’t start

Oct 29, 2020
4
0
10
0
Hello! I guess I am relatively new at building PCs so any suggestions would help. I have built my own my PC a few months ago with no problem at all so I definitely didn’t expect this. Recently went out and bought all the parts for a new one (for a friend)
I have everything plugged in and when I flip the power supply switch on, the Motherboard lights up as it should. When I hit the power button to boot it up... nothing happens. I’m assuming it’s not the power supply if It’s receiving power right? And if the motherboard is receiving power then it’s not that either??? Sorry lolz I’m trying to understand. I do know it’s not the ram as I have tried the same ram in my own PC and it worked fine. I made sure the Power Sw is placed in the right spot and I even tried it on the Reset as well. I also tried using a screw driver to start it but nothing happened. I even read somewhere that using the wrong screws can somehow prevent it. Im pretty sure I used every the right screw the first time but even so I still tried the others and nothing happened. Sorry for the long message but I’ve been at this for 2 days and I can’t think of anything else. I’ll list the specs below in case anyone needs.

Cpu:
Ryzen 7 3700x
Motherboard:
Asus TUF Gaming x570-Plus(WiFi)
Power Supply:
Cooler Master MWE 550w Gold, Fully Modular
Storage:
Inland Premium 512GB 3D M.2
Ram:
T-Force Delta RGB 32GB (2x16GB) 3200
Case:
Montech AIR X ARGB White
 

ASK THE COMMUNITY