Question Motherboard lights flash when psu is turned on but doesn't work when I try to turn it on

Nov 28, 2020
7
0
10
0
I have the Gigabyte Aorus pro wifi motherboard and the Gigabyte P650B 80 plus bronze psu. Every time that I flip the switch on the psu, the lights on my motherboard flash for a split second and immediately stop. When I try to hit the power button to turn on my pc, nothing happens. No fans turn on, no POST, nothing.
 
Nov 28, 2020
7
0
10
0
hardware should be compatible , recheck power from the psu to the motherboard
I've checked my cpu 8 pin and 24 pin connectors at least 3 times, I've also checked my gpu connector countless times.
I'm worried that somehow I managed to short circuit my motherboard. Is there any way I could tell if I short circuited it?
 

Blackink

Honorable
Apr 27, 2014
478
16
10,965
57
Is this a newly built computer or have you had it for awhile?

Can you tell, when you flip that PSU switch to on, if any of the fans even move a little? Maybe just a twitch?
 
Nov 28, 2020
7
0
10
0
Is this a newly built computer or have you had it for awhile?

Can you tell, when you flip that PSU switch to on, if any of the fans even move a little? Maybe just a twitch?
Yes I've been building this pc for the last couple of days.

When I flip the psu switch to on, the fans don't even twitch, no movement. Same with when I hit the power button to start up the pc
 

Blackink

Honorable
Apr 27, 2014
478
16
10,965
57
If you can remove the mobo from the case, plug in the 24 & 4 pin power supply, one stick of RAM, leave the CPU & cooler in/attached, and see if it'll power up then.
If not, try another ram stick, try them one at a time.
Make sure the monitor is plugged into the graphics card.
Don't connect any hard drives, you're trying to see if it;ll just POST.
 

ASK THE COMMUNITY

TRENDING THREADS