Question Motherboard no display, ram is okay

Aug 28, 2020
4
0
10
0
I have 4gb ram, asus LGA775 ddr3 motherboard and core 2 duo processor. i checked the ram in another pc, it is working. and i also changed psu and tried, still no display. I had a dual core processor too...i tried swapping core 2 duo with that too, still no display. I dont have a graphics card, it is using the onboard vga. Please tell me what I have to try other than these steps.
 
Aug 23, 2020
79
6
45
14
Just,
Try to remove and replace the silver battery in the motherboard..
Or maybe the mobo is dead.
Try to clean the ram silver pins with pencil easier gently. Sometimes pins come in the contact with carbon.
 
Aug 28, 2020
4
0
10
0
Can you tell the details of your systems ?
The motherboard is P5G41T-M LX3. I also wanted to tell you that for a long time i didnt use it and even there was no CMOS battery on it for a long time, but the light on the board is lit and also no beeps at the start.
 
Aug 28, 2020
4
0
10
0
Just,
Try to remove and replace the silver battery in the motherboard..
Or maybe the mobo is dead.
Try to clean the ram silver pins with pencil easier gently. Sometimes pins come in the contact with carbon.
Mobo is not dead since the light gets lit on connecting with psu and fans also start running. And about the CMOS battery, it wasn't present on the mobo for a long time since i wasn't using it.
 
The motherboard is P5G41T-M LX3. I also wanted to tell you that for a long time i didnt use it and even there was no CMOS battery on it for a long time, but the light on the board is lit and also no beeps at the start.
What is the RAM specs ? What kind of your CPU ? Make sure the RAM specs is 1333Mhz or PC 10600.

Wait a sec,
You have LGA 775 mobo but still there is no CMOS battery? Are you sure.?
Yeah, it is possible. They will show BIOS error on the post, but they can work and boot into windows.
 
Reactions: Agent47xD

ASK THE COMMUNITY

TRENDING THREADS