Question Motherboard Not powering On

mandeep57

Reputable
Feb 14, 2015
79
2
4,545
2
Hello,
I have Gigabye H110M S2 board
My pc was working fine but one day it didnt turned On.So i showed my pc to a repair shop and he told that Mother board is not working..my motherboard was under guarantee so i sent it to service center.When it came back my PC was again working.After 2 days again it is completely Not Powering ON at all.Please help me What to do?

Side Note : after it came from service and was working fine i was shutting it down by Window>Shutdown...But yesterday i shut it down by pressing front power button and in morning it didnt turn On

Please help me ..

SPEC :
CPU: i3 7th gen
Motherboard: Gigabyte H110M - S2
Ram: Samsung 4gb x2
SSD/HDD: 1tb
GPU: No Gpu
PSU: CoolerMaster 460 (Bought in may 2017)
Chassis: Intex(very Old)
OS: Window 10 pro 64bit
 
Last edited:

Lutfij

Titan
Moderator
When posting a thread of troubleshooting nature, it's customary to include your full system's specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Outside of the wattage of the PSU, also include the make and model of the unit as well as the age. We can then move forward from there. Also would ask you to look through the wiring in your house as bad electrical wiring can and will damage sensitive equipment.
 

mandeep57

Reputable
Feb 14, 2015
79
2
4,545
2
When posting a thread of troubleshooting nature, it's customary to include your full system's specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Outside of the wattage of the PSU, also include the make and model of the unit as well as the age. We can then move forward from there. Also would ask you to look through the wiring in your house as bad electrical wiring can and will damage sensitive equipment.
UPDATED spec

Wiring is good and i also use UPS
 

mandeep57

Reputable
Feb 14, 2015
79
2
4,545
2
Hello,
I have Gigabye H110M S2 board
My pc was working fine but one day it didnt turned On.So i showed my pc to a repair shop and he told that Mother board is not working..my motherboard was under guarantee so i sent it to service center.When it came back my PC was again working.After 2 days again it is completely Not Powering ON at all.Please help me What to do?

Side Note : after it came from service and was working fine i was shutting it down by Window>Shutdown...But yesterday i shut it down by pressing front power button and in morning it didnt turn On

Please help me ..😓😲🙁😖

SPEC :
CPU: i3 7th gen
Motherboard: Gigabyte H110M - S2
Ram: Samsung 4gb x2
SSD/HDD: 1tb
GPU: No Gpu
PSU: CoolerMaster 460 (Bought in may 2017)
Chassis: Intex(very Old)
OS: Window 10 pro 64bit
 

ASK THE COMMUNITY

Latest posts