• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Motherboard not working after switching case

Jul 9, 2020
2
0
10
0
Build:

CPU- Ryzen 3700x
Motherboard- x570 Phantom Gaming 4
RAM- Corsair Vengeance LPX 3200 16gb
Graphics card- MSI RX 580
PSU- RM650x


Hi All,

Recently I moved my build from an older case into a Fractal Design Define R6. I moved everything over into my new case and when turning it on; no display would show+ peripherals would light up for a split-second and then go off. The motherboard would show both CPU and Ram red lights and then of course without the GPU being present it would show a GPU light also, due to the 3700x not having integrated graphics.

I breadboarded the system and also built it again in my old case with a different GPU and PSU and still the same thing would occur (display would show+ peripherals would light up for a split-second and then go off).

I am quite unsure though if it is the CPU or the motherboard. However, I am leaning towards the motherboard being faulty due to it showing a ram error when I know for certain the ram works perfectly as I am using it now in my back up system. The CPU also worked perfectly before I switched cases. I am using the PSU+Ram+GPU in another system so I know they work perfectly.

I am thinking I damaged it whilst moving it. I am okay with replacing either/both parts, but I would just like to know for certain so I don't have to mess around with Amazon and returns in case one of the parts is still fully functional.

Any input is greatly appreciated.

Cheers for the help!
 

ASK THE COMMUNITY

TRENDING THREADS