Question Motherboard posts only after CMOS clear if power cord is unplugged (or from PSU)

Dec 7, 2019
1
0
10
0
So, It's my first thread ever and my first time ever posting something to find a solution (if possible).
Straight to the problem:
After the power is either disconnected from the power source or the PSU is turned off, I have to clear the CMOS with the button on the motherboard to get it to POST. Otherwise it won't POST at all.
  1. The motherboard is Asus Maximus III Gene /P55 chipset/ bundled with i7-860
  2. The PSU is RM650X (it's not the PSU)
  3. Tried with different CMOS battery
  4. Tried removing all the parts (and cables) except the CPU and the 24pin cable - still no POST, no beeps, nothing.
I got the motherboard with this problem and it was explained to me that happened after a bios update (to v2202), so I thought I could fix it. And here I am, two weekends later and the problem remains.
Tried to downgrade the BIOS. I was able to do that only with the EZ Flash utility and I was able to downgrade gradually to v1608. Could not go beyond that. Unfortunately the problem still persists and I still think is a bios problem.
Tried downgrading with AFUDOS - no luck. Got "46 error: Problem getting flash information".
Tried downgrading with older version of AFUDOS and got Error: BIOS has no flash information available

The only thing that left for me to do (and it might be from that) is that there is some rust on some places on the mobo. My last attempt would be to clean it with vinegard and isoprophyl alcohol after that and see the result, though I'm not hopeful this will help.
Anyway, I'll be happy if you have any ideas what else might be problem or why I cannot downgrade the bios with AFUDOS?
 

ASK THE COMMUNITY

TRENDING THREADS