Question Motherboard shows red CPU light on EZ debug and no post. Brand new build.

.lildemon.

Commendable
Mar 2, 2020
1
0
1,510
0
Hi, i am currently building a whole new setup and the CPU light on the motherboard is solid red and the PC won't boot at all. All the fans spin, the motherboard lights up. I tried using a and 5600x CPU with a MPG X570 Gaming pro carbon wifi. I also updated the BIOS using the USB and the flash BIOS button. It completed its update I believe as it lasted for about 7 minutes with the light on the flash BIOS button consistently flashing until the PC restarted for 2 seconds and then the button flashed twice and that was it. Then i let it run for a couple more minutes just in case and made sure that the light on the USB stick and the light on the flash BIOS button were off. I made sure to unplug everything too before i did this besides the CPU power and the motherboard power. I also did it with no CPU in the socket. That didn't work so i tried putting my 3900x from a personal computer in it which works fine and the motherboard still showed a CPU red light. I tried resetting the CMOS and jumping the pin and that did not help. I reconnected the CPU cables to the motherboard and to the power supply and that did nothing. I tried using 4 different ram sticks, 2 brand new and 2 used, and put them in every slot. Even put just one stick in I tried using the onboard video on the motherboard and the graphics cards port to see if the screen turned on. It did not. I'm thinking they sent me a bad motherboard because i don't know how i could be getting a solid red CPU light with a known working CPU designed for that motherboard. Any suggestions on what to do next would be greatly appreciated.

Build:

AMD 5600x CPU
850 watt corsair PSU
evga gtx 1050 (Yes I know that's old lol)
16 gb ddr4 RAM
4 tb HDD
1.74 TB M.2 SSD
 
Last edited:

Darkbreeze

Retired Mod
Was the motherboard in a completely shrink wrap sealed box, or was the box not sealed?

WHERE did you buy it from?

There is no onboard graphics on the 5600x, so using the motherboard video outputs will NEVER work unless you have a Ryzen CPU that ends in G, for graphics.

Can you try the 5600x in the system that the 3900x came out of? If so, that would be good just to verify the CPU works. CPUs don't commonly fail and rarely come faulty from the manufacturer, but it does sometimes happen so worth making sure.

Faulty graphics card or motherboard is far more likely.

First, I'd be sure you connected the power cables to the graphics card if it is a model that requires auxiliary power, and that the CPU power EPS 12v cables are plugged into the motherboard, in addition to the ATX power cable.

Check everything listed here.


If none of that helps, then it's likely either the graphics card or motherboard.

What are the FULL hardware specifications including memory kit model, exact power supply model, graphics card model, etc.?
 

ASK THE COMMUNITY