Question Motherboard VRM Fried?

Dec 15, 2020
1
0
10
0
I was doing some overclocking on my CPU and when I booted into Windows the computer just shut off. In the BIOS I reset to the Defaults, and it still couldn't go into Windows. I at first thought it was my Windows being corrupted and so I tried to restore my boot drive to get into windows but nothing worked.

I forced Windows safe mode and I get the account login. When I input my password and hit enter my system black screens, my keyboard and mouse RGB turns off, and exclusively my CPU fan turns off. My GPU and Case fans are still running and my motherboard's RGB is also still lit.

My roommate has recently built a new computer and has let me test a couple of things.

I put my boot drive into his computer and was able to log into my Windows on his computer. That was working so we reinstalled his boot drive on his machine.

I then put my CPU, Ryzen 5 3600, into his computer and was able to get into his Windows and even ran UserBenchmark and the CPU was fine.

I then put his CPU, Ryzen 7 3700x, into my computer and I can't even get into the mobo BIOS with that CPU installed.

The next test I planning on trying is to test my PSU on his machine but I feel like that's unnecessary considering everything but my CPU is powered.

I have come to the conclusion that my mobo's VRM's are fried and that I need to replace it. But I ask in this forum for some second opinions.

My System:
Mobo: ASUS Strix B450-I
CPU: Ryzen 5 3600
RAM: Corsair LPX 32Gb 3200MHz
GPU: ASUS Turbo RTX 2070 Super
Boot SSD: Samsung Evo 970 500Gb
HDD Cache SSD: Western Digital SN550 500Gb
HDD: 2x2TB Seagate Firecuda RAID 0
PSU: Corsair SF600

Thank you for anyhelp.
 

vov4ik_il

Commendable
Mar 23, 2020
1,215
163
1,490
138
I would reset CMOS first to undo any and all of your tinkering, then try to boot any of the live USB distros (*nix or ms) and run a benchmark and see if it fails. Also if you do have another system to test, give your RAM modules a spin there. Also borrow a PSU from that system and try it in yours.
 
The most likely reason it won't boot even into BIOS with different CPU's is the memory training was wrong for them. It crashed, and, worse, made an attempt to retrain that just left it corrupted even for the correct CPU.

The fix to that is usually a CMOS reset...as @vov4ik_il suggests. But I'd go a step further; when you do the reset leave the pins shorted for a few minutes. It can sometimes take a while to clear up that kind of mess. I needed to leave it shorted for several hours on a B350 motherboard and Ryzen 1700.
 

ASK THE COMMUNITY

TRENDING THREADS