Question Motherboard wont boot after moving all parts to a new case. Z390 AORUS MASTER

Dec 19, 2020
2
1
15
0
Problem:

Today I switched all my parts from an old case to a new case. When I tried to boot the PC it wouldn't boot. No fans are turning and no leds are turning on. The only thing that I noticed was that the power and clear cmos buttons on the MB IO shield are flickering on and off and so does the led on the top left and right of the MB.

I've removed all parts from my case and put the MB on the MB box and tried powering it with just the CPU, 1 stick of ram, and the MB itself. But still the same issue.

List anything I've done in attempt to diagnose or fix the problem.

-tried clearing CMOS

-removed the Ram sticks and switched them.

-Tried the PSU on an old pc with no problems.

-tried running the MB by itself without ram and CPU. Still had the same issue.

-removed the battery for an hour and placed it back in

-Checked if all connections where plugged in correctly.

-Checked CPU

photos and a video of the cardboard box setup.

View: https://imgur.com/a/I09Bsnu



additional details.

-When I plug everything from the PSU into my old pc and connect my AIO cooler from the corsair water pump on my current motherboard to the psu sata power connector and power the old pc on the water pump lights up and the fans start running, but when I connect everything from the PSU to the current motherboard the corsair watercooler wont light up or run.

-personally I think the Motherboard shorted for some reason. And thinking of just buying a new motherboard. Do any of you have any idea what it could be?

If you require more info Ill be glad to provide it. I already removed the setup so Can't do any additional testing at this moment. Already spent like most of the day troubleshooting so I'm done for today.

Thanks for the help.
 

ASK THE COMMUNITY

TRENDING THREADS