Mouse and K/B stop working when loadin WIN7

NoScape

Reputable
Apr 7, 2015
3
0
4,510
0
Hi,
First, sorry my bad english. My OS is in finnish, so I don't know all the right wording.
My PC was in "sleepmode". Then happened power failure. I restarted pc. As it was starting, my 2 y old son repeatedly pushed power button. Computer started up and it was complaining that it wasn't shut down properly. I tried to "continue using" and screen went black. Cpu was running. I booted cpu from powerbutton. When it started and again there was this "wasn't shut down properly". I selected normal start up.

When windows is starting (logo on black background) my k/b and mouse stops working.
As windows starts up, I can't choose user account. In bios, both work normally. I have ps/2 interface on my MB, but it doesn't work for some reason. It gets power (k/b and mouse laser is lit up) but it doesn't have any effect (nor bios and windows). I can't find setting in bios that allows me to enable or disable ps/2.

When k/b or mouse is connected from start up, they have some contact when windows is loaded. When I push mousebutton, laser flashes, when I press button from k/b, it's lit up for like a sec. But there's no effect. If I dis- and reconnect them, theyre both dead.

I have tried many different things to repair this problem, without any luck.
1. remove mouse and k/b and start up computer. Reconnect them back, when windows has been loaded.
2. checked that usb is enabled in bios. Yes, it finds both k/b and mouse and two hubs
3. No matter, which usb port I try
4. sfc/scannow from command prompt: no problems found
5. I have took out battery from mb

Motherboard is msi p67a-c45 (b3). OS is Windows 7bit.

Any help?
 

Dee Kay

Reputable
Dec 22, 2014
863
0
5,360
145
Check you mouse and kb on another system to make sure they work correctly. Check to see if the mouse, kb, and USB hub in device manager for problems. Make sure you have any needed USB3 drivers on a flash drive and then delete the hub if a problem and let windows reinstall at boot. Just don't delete the top header where USB is listed and you should be fine. Same thing for mouse and keyboard.

P.S. Your english is actually a lot better than some of the native speakers so nothing to apologize for. :)
 

NoScape

Reputable
Apr 7, 2015
3
0
4,510
0


Thank You for reply. I've tried another mouse and same thing. And both work just fine in bios. Please, can You guide me how to get in device manager? I can't get in windows, I only can use command prompt on system recovery environment (F8 on boot or installation dvd).

When I get in command prompt, should I go to drive I have windows installed? By typing D? And after that type "mmc devmgmt.msc" <found that on another site.

I'm not used to operate computers on command prompt. :/

 

Dee Kay

Reputable
Dec 22, 2014
863
0
5,360
145
Yes, go to where windows is located to get to device manager how you entered it. See if booting from the install disc will allow you to use your kb long enough to get to safe mode. That may give you the opportunity to make changes in windows if it works.
 

NoScape

Reputable
Apr 7, 2015
3
0
4,510
0
Is it just me or why I can't get in devmgmt.

I did startup repair with system re (disc) and there were no mistakes. After that I did startup repair from f8 (without disc) and it found 0x490 "program repair prevents system start up. System recovery cancelled". What now :D
 

ASK THE COMMUNITY