[SOLVED] Mouse and keyboard dont work when installing windows 7

Jul 30, 2020
70
2
35
0
I was trying to install windows 7 on a new PC. I made a bootable stick using rufus and after going into the bios and booting from the stick windows 7 loads all fine and dandy but as soon as the loading screen is over and im greeted by the "Install Windows" screen where im first asked to choose install language, time and currency format and the keyboard input layout i cant do anything. my mouse and keyboard wont work, i cant choose any options or continue the installation. I have tried unplugging and plugging both mouse and keyboard back in while in this screen and i made sure that both of them are plug and play, meaning i dont need a driver installation first. they shouldnt be the problem, i assume i did something wrong with the boot stick?
 

boju

Titan
Ambassador
Most likely because your hardware has usb3 which Win7 doesn't have native support for prior to installing. Need to inject usb3 driver into the boot media for it to recognise your peripherals


Bear in mind though, even if you do succeed with this, do check first for driver support which most likely isn't any if your system is too modern.
 

Zerk2012

Titan
Ambassador
I was trying to install windows 7 on a new PC. I made a bootable stick using rufus and after going into the bios and booting from the stick windows 7 loads all fine and dandy but as soon as the loading screen is over and im greeted by the "Install Windows" screen where im first asked to choose install language, time and currency format and the keyboard input layout i cant do anything. my mouse and keyboard wont work, i cant choose any options or continue the installation. I have tried unplugging and plugging both mouse and keyboard back in while in this screen and i made sure that both of them are plug and play, meaning i dont need a driver installation first. they shouldnt be the problem, i assume i did something wrong with the boot stick?
Plug them into a USB 2.0 port if you have them.
 
Jul 30, 2020
70
2
35
0
Plug them into a USB 2.0 port if you have them.
The plugs i used are USB 2.0 which confused me after seeing what the other two told me. I've done USB installation toll from boju and im now doing the image updater math geek linked, though i just read that not unchecking "apply to all editions" can make the process take a pretty long time im confident that itll not take that long and im already to long into the process to restart now. Ill update once im done with that.
 

Math Geek

Champion
Ambassador
yah sorry about that. i forgot how long it takes if you do every version.

it is still a couple hour process even for 1 edition. i ran this on my win 7 and had no problem installing it on my mobo which does not even have a 2.0 usb slot!! did not even notice that when i bought it but it's all 3.* ports.

i've also usedit on many other new machines. both amd and intel. i have not had it fail yet on me, so at this point it seems to work on everything. do let me know if you find it does not work for you so i can make note if i see the same mobo asked about again.
 
Jul 30, 2020
70
2
35
0
yah sorry about that. i forgot how long it takes if you do every version.

it is still a couple hour process even for 1 edition. i ran this on my win 7 and had no problem installing it on my mobo which does not even have a 2.0 usb slot!! did not even notice that when i bought it but it's all 3.* ports.

i've also usedit on many other new machines. both amd and intel. i have not had it fail yet on me, so at this point it seems to work on everything. do let me know if you find it does not work for you so i can make note if i see the same mobo asked about again.
i aborted the process 20 minutes in after nothing changed for 5 minutes and only selected the version i needed. was done in about 80 minutes this time. but now im left with an .iso file that is 0KB in size and i cant do anything with it. the motherboard im using is the H310i
 

Math Geek

Champion
Ambassador
mine is 6.6 gb but it's a complete iso with every version 32 and 64 bit!! so it started out large. i started it for all versions and then went to bed. it was almost done when i woke up. lol

obviously it should be about the same size as you started with. you may have to start again with a fresh untouched iso.
 
Jul 30, 2020
70
2
35
0
mine is 6.6 gb but it's a complete iso with every version 32 and 64 bit!! so it started out large. i started it for all versions and then went to bed. it was almost done when i woke up. lol

obviously it should be about the same size as you started with. you may have to start again with a fresh untouched iso.
ive rerun the entire process again and this time it seemed to work. i got a 4-5GB iso file and mouse and keyboard where recognized allowing me to do the installation. thanks a lot!
 

ASK THE COMMUNITY

TRENDING THREADS