Question Mouse keeps moving slightly even after disabling trackpad, bluetooth, and touchscreen (Asus Zenbook Flip 14 UX461)

panpaper

Reputable
Dec 8, 2016
32
0
4,540
1
I got a screen replacement for my laptop at a repair shop after I tripped over the charging cable. After I got it back, I found that the cursor would "activate" every now and then. To clarify, if I had a youtube video in fullscreen, the video toolbar would appear randomly for a split second (as if I moved the mouse or touched the screen). Sometimes, the mouse would suddenly disappear as I was moving it around, which usually happens when the touchscreen is touched. At other times, the cursor would just appear at a completely random position.

At first, I thought it was a touchscreen issue, since the replacement was not the OEM screen, but the problem persisted even after I disabled the touchscreen in device manager. Then I thought maybe the touchpad was damaged too, so I disabled the touchpad - still not fixed. Finally, I thought maybe it was my bluetooth mouse, so I turned off bluetooth, it still persists. I've listed below all the things I tried:
  • Disabled touchscreen in device manager
  • Disabled touchpad
  • Disabled bluetooth
  • All of the above at the same time
  • Uninstalled touchpad and touchscreen in device manager
  • Factory reset (Windows 10)
  • Installed Linux (Ubuntu)
So I'm all out of options now...

My laptop information:
Asus Zenbook Flip 14 (UX461UA)
Damage observed on screen only before sending for repair
Windows 10
Roughly 2 years old now
Touchpad driver: HID compliant touch pad, Asus precision touchpad

Any informed guesses would be highly appreciated!
 

hang-the-9

Titan
Moderator
I'd say touchscreen is the issue since you had it replaced. Really would be impossible to tell for sure since the thing was opened and parts swapped. Nothing points to anything for sure aside from the replacement and the fact whoever did the work would have had to take the thing apart.
 

panpaper

Reputable
Dec 8, 2016
32
0
4,540
1
So I tried a bunch of other things and it looks like it's working fine now. Posting it here in case someone else has a similar problem.

It could be one of the following or a combination of some, I did all of them and didn't want to touch the settings again in case I screw something up.

  • Go to control panel > Hardware and Sound > Mouse
    • Go to the "Pointer Options" tab and uncheck the "Enhance pointer precision"
    • Uncheck "Hide pointer while typing" (probably the most important one)
  • Go to Device Manager
    • Disable HID compliant touch
    • Disable HID compliant pen input
  • Go to settings
    • Change touchpad sensitivity to "Low sensitivity"
 

ASK THE COMMUNITY