mouse lag csgo/win10

Oct 15, 2018
5
0
10
0
Basically I was having mouse lag problems that include the mouse being very sluggish and hard to move. As if im dragging it through mud or something of that type. Very unresponsive to tiny movements aswell like I cant strafe normally I just feel like im using my feet to play. So I bought a completely new pc because I wanted to upgrade either way and I have exactly the same identical problem! I have even changed my mouse and its still the same problem. I clean installed windows 10, barely touched anything and just downloaded my mouse drivers/chipset etc. and launched csgo. At first when I play it is fine, but as the time goes on my mouse sometimes randomly becomes sluggish and it will stay like that forever. I am so confused as to how to solve this problem, ive changed all my hardware except my keyboard and monitor. Dont know what else to do :(
 
Jan 22, 2018
443
1
965
82
A couple of simple things you may have already tried: check the windows mouse settings, and make sure the speed is at max; open the Logitech software and adjust the dpi and polling rate settings. Sometimes odd stuff happens. Switching between onboard and pc memory may also help.

Assuming those things have been tried:

Well, for the Zowie, I wouldn't trust any non-windows drivers (very few peripheral makers have decent enough software) . The Logitech on the other hand... those drivers are usually on point. First I would see if using a USB 2.0/1 rather than 3.0 port helps (or the other way around if you're already using the 2.0/1). Then uninstall the branded drivers and have windows install standard drivers (just to see if you can get it working at a "normal" rate); make sure only one driver is installed at a time.

Then try to install the Logitech driver for the logitech mouse (if that's the one you're using) and open the software and adjust the settings from there.

Device Manager will be your friend in all this.

I'm not sure what else I'd try in your position. Good luck.
 

captain wajji

Honorable
Jul 9, 2012
199
0
10,690
1


Are you playing on 2K or 4K?

If yes then the display cable you're using doesn't support 2k or 4k. I had the same problem a few days back on a 4k monitor where I connected a 4k monitor with a cable that didn't support 4k. My mouse was laggy.

It's just the cable. The monitor you're using will clarify everything.
 

captain wajji

Honorable
Jul 9, 2012
199
0
10,690
1


It's the CABLE of his monitor that doesn't support 2k/4k so the mouse is laggy.

Changing the cable/port to at least 60Hz will fix this.
 
Jan 22, 2018
443
1
965
82


Alright, cool yer jets, you don't have to specially reply to me with bold like I intentionally ignored or undermined you (I left my post the day before, so couldn't have known that you would offer a different solution a day in the future). I answered what I would do, which is how I have solved mouse lag of my own in the past. If your solution works, then great, the OP get's their problem fixed and you get the green border.
 

captain wajji

Honorable
Jul 9, 2012
199
0
10,690
1


Looks like someone woke up on the wrong side of the bed today.
 
Sep 11, 2018
12
0
10
0
Did you fix it? I know you selected the best answer but you never mentioned having a 2k or 4k monitor. I'm having the same issue.. 144HZ monitor playing on 4:3 1280x960 all low settings with a zowie za12
 
Jan 13, 2019
20
0
10
0
I have zowie ec-2B And I have same problem for like a month I am playing on 4:3 1280x1024 And have this laggy mouse on small mouse movements, It s not mouse And mousepad problems Because I have tried with my old mouse Genesis GX57 And still same. I have tried all usb ports And still same, I tried reinstall Windows too. Please help me
 
Jan 22, 2018
443
1
965
82


You'll want to make a new thread for that, it'll get you the most traffic and best chances of finding help.
 

ASK THE COMMUNITY

TRENDING THREADS