Question Mouse lagging after playing fullscreen 800x600 game

WolfyB

Distinguished
May 23, 2012
39
0
18,530
0
So I've got a really weird issue with my pc. I say that because I'm sure it isn't my mouse as I've tested it on another computer and it behaves the way it did before this problem began. Basically I was playing an old game the other day and I put it into fullscreen, it only allows you to play fullscreen in 800x600 for this game. After I was done playing I closed the game an immediately noticed now there is a significant lag with my mouse on the desktop and in other games. It feels like my monitor is on 30fps essentially, but it isn't.

Things I've tried so far:
I've checked the monitor settings in windows and nvidia and both are set to 60fps. Checked my mouse settings and they are all how they should be as far as I can tell. Tried restoring to an old system restore point which also didn't help. I tried uninstalling all the mouse drivers in device manager then rebooting, still nothing. I'm all out of ideas other than a clean install of windows.

I've been doing some searching online and have found tons of people with laggy mice issues, but none that match my scenario. I know its software related as like I said before I've tested my mouse on another computer and it works normally. One thing I tried was switching my desktop resolution to 800x600 and then my mouse will act normally, but as soon as I switch it back to 1920x1080 or any other resolution it is laggy again. I'm on Windows 7 btw. Any ideas would be greatly appreciated.
 
Last edited:

Lutfij

Titan
Moderator
You might want to mention the make and model of the mouse. I play Red Alert 2 and that too on the same resolution as you've mentioned but I don't have a mouse lag issue, I have a mouse DPI issue where I need to change the DPI on my mouse to cater to the smaller realestate.

Might want to see if reinstalling your chipset drivers manually alleviates the problem. Might also want to list your specs for good measure in case we miss something.
 

WolfyB

Distinguished
May 23, 2012
39
0
18,530
0
You might want to mention the make and model of the mouse. I play Red Alert 2 and that too on the same resolution as you've mentioned but I don't have a mouse lag issue, I have a mouse DPI issue where I need to change the DPI on my mouse to cater to the smaller realestate.

Might want to see if reinstalling your chipset drivers manually alleviates the problem. Might also want to list your specs for good measure in case we miss something.
My mouse is a logitech G703 and I've also tested a logitech G402 and both have the same issue. I've tested both mice on my laptop and they behave normally. Can you elaborate on reinstalling my chipset drivers? I'm not sure what you're referring to or how to do that.


My specs:

msi z97 gaming 5
i7 4790k
evga gtx 1080 sc
16 GB DDR3 Corsair vengeance
samsung 850 evo ssd 1TB
 

WolfyB

Distinguished
May 23, 2012
39
0
18,530
0
Starting to think it's hardware related, but not my mouse for reasons mentioned above. I did a clean install of Windows 10 on my m.2 drive and the issue was still there as soon as I freshly booted into it for the first time. It was also there when I was going through the Windows 10 installation from my usb drive. Maybe something with a component went wrong and it just coincidentally happened while I was playing my game? I have no idea at this point.
 

WolfyB

Distinguished
May 23, 2012
39
0
18,530
0
Figured it out: My TV has been on the fritz for some time. Changed HDMI ports and the problem disappeared. Don't know why or how, but apparently that HDMI port went bad somehow. Video and audio still works fine just guess the signal is delayed a bit. Hope this helps someone in the future.
 

ASK THE COMMUNITY

TRENDING THREADS